2009 Liberty Limited Third Light Problem - JeepForum.com

 
LinkBack Thread Tools
post #1 of 1 Old 01-07-2012, 10:30 AM Thread Starter
mrgj
Registered User
 
Join Date: Jan 2012
Location: Baton Rouge
Posts: 1
2009 Liberty Limited Third Light Problem

The third light fails to light up when brakes are applied. M1 Fuse and light bar check out fine, but power to light at connector is not there. Could this be a ground problem, and if so, where is that ground located? All other lights work fine. If another possible problem, please advise. Many thanks.

mrgj is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.



Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Similar Threads
Thread Thread Starter Jeep Forums Replies Last Post
Transmission issues on a 2009 Jeep Liberty Limited csell KK Liberty Forum 10 05-08-2015 07:44 PM
Jeep Liberty KK 2009 LibertyJ KK Liberty Forum 6 05-27-2011 08:02 AM
Inner tie rod Jeep Liberty 2009 KK suzuki_gixxer KK Liberty Forum 15 09-27-2010 02:30 AM
2009 Liberty... Any tow points? AmnWatkins KK Liberty Forum 8 09-21-2010 07:46 PM
Prices Paid for 2009/2010 Liberty Limited britt22 KK Liberty Forum 10 06-14-2010 12:15 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome