2009 Liberty Limited clicks instead of starting - JeepForum.com
Search  
Sign Up   Today's Posts
User: Pass: Remember?
Advertise Here
Jeep Home Jeep Forum Jeep Classifieds Jeep Registry JeepSpace Jeep Reviews Jeep Gallery Jeep Clubs Jeep Groups Jeep Videos Jeep Events Jeep Articles
Go Back JeepForum.com > Models > Jeep Liberty Forums > KK Liberty Forum > 2009 Liberty Limited clicks instead of starting

Rockridge 4WD IS Taking Zone Offroad Suspension Lift Kits End of Summer Sale, 20% OFF!ZONE 4.25" combo lift for TJ available at Rockridge4w

Reply
Unread 04-04-2013, 11:40 AM   #1
Libertyugh87
Registered User
 
Join Date: Apr 2013
Location: Maple Shade, NJ
Posts: 1
2009 Liberty Limited clicks instead of starting

I have a Jeep Liberty Limited 2009 that occasionally will not start right away. I have already had my battery replaced, my starter replaced and the wiring from the starter to the ignition. When it won't start it just makes a click noise, but then will eventually start after a few tries. Sometimes it only clicks once then starts but other times it has not started for over 20 minutes. This often occurred after I used the factory remote starter, the car starts initially but the next time I go to start my car with the key is when I would get the click and no start.

I went three months without using the remote starter and it only happened once in that time frame. I used the remote starter everyday last week in the morning and my car didn't start 3 different times soon after. I have a log of every time this occurs; date, time of day, temperature, etc. It often occurs on a day were it is raining or very damp out. I have had my car to 3 different Jeep dealers and only one was able to duplicate the issue. However they were not able to diagnose the problem because "nothing came up on their computer flagging an error". Please help!

Thanks

Libertyugh87 is offline   Reply With Quote
Unread 04-04-2013, 11:45 AM   #2
Gageraid
Registered User
2008 KK Liberty 
 
Join Date: May 2012
Location: Branchburg, New Jersey
Posts: 1,352
Hmmm I think there might be another member or two that will be able to chime in on this problem.

I know in the past, mostly older cars, have had problems starting when it's raining or moist out, but I have a feeling it won't be related on this one.
Gageraid is offline   Reply With Quote




Jeep, Wrangler, Cherokee, Grand Cherokee, and other models are copyrighted and trademarked to Jeep/Chrysler Corporation. JeepForum.com is not in any way associated with Jeep or the Chrysler Corp.