2009 Jeep Liberty Issues - JeepForum.com
 
LinkBack Thread Tools
post #1 of 11 Old 12-04-2009, 08:51 PM Thread Starter
JBWrangler2000
Registered User
1989 YJ Wrangler 
 
Join Date: Oct 2006
Location: Delaware
Posts: 50
2009 Jeep Liberty Issues

Hey everyone. I purchased a brand new 2009 Liberty about 3 months ago and have already had a couple of minor problems. First, the touch-screen radio shorted out and had to be replaced. This week the instrument cluster shorted out and the Jeep was at the dealership for two days before it too was replaced. I was just wondering if anyone else has had any similar issues? I love my Jeep but am upset that I'm having issues with only 3000 miles on the odometer. Also wondering if I have any more problems to look forward to. Thanks in advance for any replies!

JBWrangler2000 is offline  
Sponsored Links
Advertisement
 
post #2 of 11 Old 12-05-2009, 05:10 PM
Cars76
Registered User
2014 WK 
 
Join Date: Oct 2009
Location: New Jersey
Posts: 15
I have my 09 Liberty for 4 month's with 3100 miles on it. No problems so far but I do not have the touch screen radio.

2014 Grand Cherokee.3.6L. 8 Speed
Cars76 is offline  
post #3 of 11 Old 12-05-2009, 05:20 PM
LibertyTC
Registered User
2004 KJ Liberty 
 
Join Date: Sep 2008
Location: Vancouver B.C.
Posts: 907
Sorry to hear about the new KK woes.
The good news is that it is under warranty, and the bugs get fixed early in life.
I hope you have a better experience from here....
LibertyTC is offline  
post #4 of 11 Old 12-05-2009, 05:22 PM Thread Starter
JBWrangler2000
Registered User
1989 YJ Wrangler 
 
Join Date: Oct 2006
Location: Delaware
Posts: 50
Thanks for the replies. I know they're only minor issues but frustrating none the less. Hopefully no more troubles from here on out
JBWrangler2000 is offline  
post #5 of 11 Old 12-13-2009, 11:56 AM
GearGuy10
Registered User
1998 XJ Cherokee 
 
Join Date: Aug 2005
Location: St. Paul, Minnesota
Posts: 489
No real issues here. I have a slight leak from the tranny pan that I need to have the dealership take care of. About a drop a day. I also had a mouse build a nest under the hood and chew through a wire. No idea how that happened. Just popped the hood to check the oil level and there it was. I've heard of it happening to people who live in the country, but I'm in the city and it is parked in a garage all the time. Did a little home electrical fix on that one.

When I had my KK in for an oil change the dealership had a new KK in the garage with the dash out and all the wiring pulled out. The tech said it had some kind of electrical bug they were trying to figure out. Made me kinda nervous to see that. I mean there were wires all over the place. They even had the door panels off and the wiring pulled out of there too.

HIS: 1998 Cherokee Sport Chili Pepper Red-SOLD
DrawTite front hitch

HERS: 2009 Liberty Sport Light Graystone Pearl
100% Stock
GearGuy10 is offline  
post #6 of 11 Old 01-21-2010, 07:27 PM
daledoe
Registered User
2009 KK Liberty 
 
Join Date: Jan 2009
Location: Fort Stewart, GA
Posts: 12
Ive had mine for 13 months now, no electrical problems but a possible water leak with the rear window.
daledoe is offline  
post #7 of 11 Old 01-22-2010, 04:07 AM
jeepster09
Registered User
2009 KK Liberty 
 
Join Date: Aug 2009
Location: michigan
Posts: 39
My 09 KK just turned 10K, zero problems
jeepster09 is offline  
post #8 of 11 Old 01-23-2010, 01:17 PM
Roadster71
Registered User
 
Join Date: Nov 2007
Location: CT
Posts: 17
Quote:
Originally Posted by JBWrangler2000 View Post
Hey everyone. I purchased a brand new 2009 Liberty about 3 months ago and have already had a couple of minor problems. First, the touch-screen radio shorted out and had to be replaced. This week the instrument cluster shorted out and the Jeep was at the dealership for two days before it too was replaced. I was just wondering if anyone else has had any similar issues? I love my Jeep but am upset that I'm having issues with only 3000 miles on the odometer. Also wondering if I have any more problems to look forward to. Thanks in advance for any replies!
11K and no problems
Roadster71 is offline  
post #9 of 11 Old 01-24-2010, 01:15 PM
diggerfreek
Registered User
2008 KK Liberty 
 
Join Date: Dec 2008
Location: Aurora Colorado
Posts: 145
18K on my 08 with no electrical problem...
diggerfreek is offline  
post #10 of 11 Old 09-29-2010, 09:30 AM
jerryfd276
Registered User
2009 KK Liberty 
 
Join Date: Sep 2010
Location: staten island
Posts: 1
lets see, my 09, hazard lights stopped working, cluster need to be replaced, front passenger speaker blew, all less then 13k miles. other then runs great.
jerryfd276 is offline  
post #11 of 11 Old 09-29-2010, 09:55 AM
Elt31987
Senior Member
 
Elt31987's Avatar
2008 KK Liberty 
 
Join Date: Mar 2009
Location: Stoneham, Massachusetts
Posts: 944
Welcome to the Forum and sorry to hear about the bad news

---------------------------------------------------
2008 KK Liberty
Inferno Red
Daystar 2" Spacer Lift With SkyJacker Hydro Shocks
JBA Gen 5.5 Upper Control Arms
Rokmen Riddler 8.25 Differential Cover
2 KC Slimlite 100 Watt Driving Lights on JK Light Bar
245/75/16 All Terrains
Mopar Front Tow Hooks
Mopar Rear Tow Hook
Mopar Skids
Elt31987 is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.



Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Similar Threads
Thread Thread Starter Jeep Forums Replies Last Post
2009 jeep liberty - wont start / wont even crank aimetti KK Liberty Forum 38 02-19-2016 09:46 AM
Help: jeep liberty 2009 8" ROOF antenna NEEDED bobbarto KK Liberty Forum 25 09-09-2011 05:52 AM
2010 Jeep Liberty- Worth buying? jkwik KK Liberty Forum 68 10-17-2010 10:56 AM
2010 Jeep Liberty with Sun Slider vs. 2010 4dr. Unlimited ?? britt22 KK Liberty Forum 20 10-08-2010 12:49 PM
Prices Paid for 2009/2010 Liberty Limited britt22 KK Liberty Forum 10 06-14-2010 12:15 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome