2009 Jeep Liberty Instrument Panel Problems - JeepForum.com
Search  
Sign Up   Today's Posts
User: Pass: Remember?
Advertise Here
Jeep Home Jeep Forum Jeep Classifieds Jeep Registry JeepSpace Jeep Reviews Jeep Gallery Jeep Clubs Jeep Groups Jeep Videos Jeep Events Jeep Articles
Go Back JeepForum.com > Models > Jeep Liberty Forums > KK Liberty Forum > 2009 Jeep Liberty Instrument Panel Problems

Introducing MONSTALINER™ UV Permanent DIY Roll On Bed LineFS: Jeep Fog Light LED Bulbs! Several Brightness Options! Clayton Off Road JK Short Arm Suspension Kits

Reply
Unread 12-08-2013, 06:03 AM   #1
kmhussey22
Registered User
 
Join Date: Dec 2013
Location: APO, AE
Posts: 2
2009 Jeep Liberty Instrument Panel Problems

Hello All,
First post here... couldn't locate anything similar to my problem, so hope someone can help. My wife has a 2009 Liberty and yesterday when getting into the car, she noted the area on the instrument panel that displays the compass and mileage was not on... I proceeded to do some testing, and I checked the fuse box, primarily location M20, but looked at quite a few others, and can't seem to locate a faulty fuse. The gauges lights work and the gauges function. Everything seems to work normally as far as head lights, fog lights, emergency break, etc, but the cluster won't reflect any of that.
Now I don't have a dealer to bring it to, because I live overseas, and it appears the 09 doesn't have any type of user manual published, so I am really looking for some help.
Anyone had this problem, or have any ideas?
Thanks!!!!

kmhussey22 is offline   Reply With Quote
Unread 12-08-2013, 08:39 AM   #2
Yakker
Registered User
2008 KK Liberty 
 
Join Date: Jul 2013
Location: London,Ont.
Posts: 29
Disconnect battery for a few minutes-it may reset itself-might seem silly but sometimes works.........fingers crossed
__________________
Blacked out headlights,Mopar hitch,255/70/16 AT2s,racks for the yaks-missing front air dam since a wild ride in Wyoming in 2010
Yakker is offline   Reply With Quote
Unread 12-09-2013, 09:02 AM   #3
kmhussey22
Registered User
 
Join Date: Dec 2013
Location: APO, AE
Posts: 2
Already tried the battery... anyone else that can help me???
kmhussey22 is offline   Reply With Quote




Jeep, Wrangler, Cherokee, Grand Cherokee, and other models are copyrighted and trademarked to Jeep/Chrysler Corporation. JeepForum.com is not in any way associated with Jeep or the Chrysler Corp.