2008 JEEP LIBERTY, heater blowing cold air - JeepForum.com
 
LinkBack Thread Tools
post #1 of 3 Old 11-13-2013, 07:47 AM Thread Starter
s2kimportlover
Registered User
 
Join Date: Nov 2013
Posts: 3
2008 JEEP LIBERTY, heater blowing cold air

2008 jeep liberty, heater blows cold, temperature gauge goes all the way to the middle, dont matter if I am on the highway or a school zone, the heater always blows cold!! last week it was working fine, today it got really cold and for some reason it don't work anymore, help please!!!

s2kimportlover is offline  
Sponsored Links
Advertisement
 
post #2 of 3 Old 11-14-2013, 11:07 AM Thread Starter
s2kimportlover
Registered User
 
Join Date: Nov 2013
Posts: 3
no one??? please help
s2kimportlover is offline  
post #3 of 3 Old 11-14-2013, 12:14 PM
Babaki
Registered User
2012 KK Liberty 
 
Join Date: Aug 2013
Location: North Jersey
Posts: 113
if the temp is normal maybe its the blend door. either its stuck or busted. there is fuse that control this that could be bad but i dont know the number off the top of my head.
Babaki is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.



Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome