2008 Jeep Liberty drivers side rear blinker not working. - JeepForum.com
Search  
Sign Up   Today's Posts
User: Pass: Remember?
Advertise Here
Jeep Home Jeep Forum Jeep Classifieds Jeep Registry JeepSpace Jeep Reviews Jeep Gallery Jeep Clubs Jeep Groups Jeep Videos Jeep Events Jeep Articles
Go Back JeepForum.com > Models > Jeep Liberty Forums > KK Liberty Forum > 2008 Jeep Liberty drivers side rear blinker not working.

Rampage Bowless Soft Top Oconee offroadAlloy USA Still AvailableAdvance Adapters SYE Kits

Reply
Unread 07-18-2014, 03:13 PM   #1
Jeep1530
Registered User
 
Join Date: Jul 2014
Location: Panama City Beach, Florida
Posts: 2
2008 Jeep Liberty drivers side rear blinker not working.

2008 Jeep Liberty drivers side rear blinker not working.
Changed bulb and circuit board and still nothing. Bought a test light and I'm not get any power to that bulb.
Check to see if I was getting power to the plug by testing the wire going into and nothing.
To make sure I was checking it right I tested the passenger side and it was working at it should.
Front blinker works and the turn indicator on the dash works but clicks fast as if the bulb is blown.
Checked fuses and it has one for the left and right and both are good.
Check light with hazards on and it's only the one light not flashing.

I was thinking that if it was the lever on the column it wouldn't let neither front or back work on that side.

Any suggestions?

Jeep1530 is offline   Reply With Quote Quick reply to this message
Unread 07-19-2014, 03:43 AM   #2
Drednot
Registered User
1991 YJ Wrangler 
 
Join Date: Aug 2005
Location: phoenix, az
Posts: 1,408
Well you've checked all the obvious stuff. Now you need to trace the harness looking for breaks or corroded connectors.
Do you have factory or aftermarket trailer lights?
__________________
91 YJ Sahara, 4.0L, AX-15/NP231, D30/D35
12 Cherokee 4x4,3.7L,
"Non Vi Sed, Arte"
Drednot is offline   Reply With Quote Quick reply to this message
Unread 07-19-2014, 05:21 AM   #3
Jeep1530
Registered User
 
Join Date: Jul 2014
Location: Panama City Beach, Florida
Posts: 2
It has trailer lights but I also checked before the connection. The blinker isn't working on the trailer lights either. Will that wire be the only one with that color combination in the wiring harness that runs to the fuse box? Electrical just isn't my thing but I'll never figure it out until I just jump in and do it.
Jeep1530 is offline   Reply With Quote Quick reply to this message
Unread 07-19-2014, 10:10 AM   #4
avatr
Registered User
2012 KK Liberty 
 
Join Date: Mar 2014
Location: San Antonio, TX
Posts: 42
sounds like one of the bulbs are bad. have you tried swapping in a good one for the front and back?
avatr is offline   Reply With Quote Quick reply to this message
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.
Note: All free e-mails have been banned due to mis-use. (Yahoo, Gmail, Hotmail, etc.)
Don't have a non-free e-mail address? Click here for a solution: Manual Account Creation
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.


Thread Tools






Jeep, Wrangler, Cherokee, Grand Cherokee, and other models are copyrighted and trademarked to Jeep/Chrysler Corporation. JeepForum.com is not in any way associated with Jeep or the Chrysler Corp.