2006 jeep liberty engine issue - JeepForum.com

 
LinkBack Thread Tools
post #1 of 2 Old 05-04-2013, 09:29 AM Thread Starter
SheilaC
Registered User
 
Join Date: May 2013
Posts: 1
2006 jeep liberty engine issue

I have a 2006 jeep liberty 3.7L 4wd with 61,000 miles on it. I bought it used in 2010. My check engine light has been on more or less ever since. The first thing we did was replace the head gaskets because we noticed it was also using anti freeze. We were told the head itself was fine. Light came back on approximately 3 months later. We have since replaced all fuel injectors, ignition coils, fuel rails, radiator, and all oxygen sensors. We are out of ideas and cash. Could use some serious help. Any suggestions?

SheilaC is offline  
Sponsored Links
Advertisement
 
post #2 of 2 Old 05-04-2013, 11:45 AM
mrbeal
Registered User
2011 JK Wrangler 
 
Join Date: Apr 2013
Location: Norwell
Posts: 83
I'd say take it back and have the head gasket done right. Sounds like it overheated and wasn't fixed properly.

Steve
'11 JK Flame Red
mrbeal is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.



Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome