12 Libertyand some issues - JeepForum.com
Search  
Sign Up   Today's Posts
User: Pass: Remember?
Advertise Here
Jeep Home Jeep Forum Jeep Classifieds Jeep Registry JeepSpace Jeep Reviews Jeep Gallery Jeep Clubs Jeep Groups Jeep Videos Jeep Events Jeep Articles
Go Back JeepForum.com > Models > Jeep Liberty Forums > KK Liberty Forum > 12 Libertyand some issues

FS: 2007-2013 Jeep Wrangler "HALO" Angel Eye KitFS: Wranger BRIGHT License Plate LED! Just $3! Great valueIntroducing MONSTALINER™ UV Permanent DIY Roll On Bed Line

Reply
Unread 06-25-2015, 12:48 PM   #1
esu
Registered User
1995 ZJ 
 
Join Date: Sep 2012
Location: STATEN ISLAND, ny
Posts: 146
12 Libertyand some issues

Hey, picked up a 12 Liberty Latitude for my daughter. SHes stoked but when we got it home we picked up on some problems we didnt see while at the dealer. Since the dealer is 60 miles away and usually involves a ton of traffic I was thinking about just trying to fix myself. Issues:
1. volume control on rear of steering wheel will lower volume but not raise it.
2. auto headlights dont work.
3. power wire that attaches to the rear window defogger on drivers side is detached from the window/defogger.

1. Maybe just the control itself? Easy to change? Expensive?

2. I saw on this forum that disconnecting the battery for a few minutes cleared one guys problem with the auto headlights. Sure is simple enough but Im not sure why it would fix the problem? The sensor Im guessing is located on top of the dash? Tough or expensive to change?

3. I could bring the car to a local glass shop and have the connector soldered back on the rear window, shouldnt take too long or cost that much, maybe do it myself?

Thoughts?

Or just hump it to the local dealer which is closer but a real nightmare to deal with or spend a day or so and take it back where we bought it? Certified Jeep by the way, you would think the dealer would have it tottally ready to go.

esu is offline   Reply With Quote Quick reply to this message
Unread 06-26-2015, 12:25 PM   #2
esu
Registered User
1995 ZJ 
 
Join Date: Sep 2012
Location: STATEN ISLAND, ny
Posts: 146
hmmm 269 views and no opinions? I disconnected the battery for 5 minutes then re-connected. The auto headlights worked then stopped working again. No idea what that means, I guess its off to the dealer.
esu is offline   Reply With Quote Quick reply to this message
Unread 06-26-2015, 12:47 PM   #3
DrD28
Registered User
 
Join Date: Nov 2013
Posts: 122
I would just take it in
DrD28 is offline   Reply With Quote Quick reply to this message
Unread 06-26-2015, 01:27 PM   #4
avatr
Registered User
2012 KK Liberty 
 
Join Date: Mar 2014
Location: San Antonio, TX
Posts: 102
Quote:
Originally Posted by DrD28 View Post
I would just take it in
yep.
avatr is offline   Reply With Quote Quick reply to this message
Unread 06-26-2015, 09:53 PM   #5
esu
Registered User
1995 ZJ 
 
Join Date: Sep 2012
Location: STATEN ISLAND, ny
Posts: 146
made the appointment with the local dealer, cant wait to hear his crap that I bought it somewhere else.
esu is offline   Reply With Quote Quick reply to this message
Unread 06-30-2015, 08:28 AM   #6
JeepCares
FCA Customer Care
 
JeepCares's Avatar
 
Join Date: Jan 2012
Location: MOPAR World Headquarters
Posts: 2,848
Quote:
Originally Posted by esu View Post
Hey, picked up a 12 Liberty Latitude for my daughter. SHes stoked but when we got it home we picked up on some problems we didnt see while at the dealer. Since the dealer is 60 miles away and usually involves a ton of traffic I was thinking about just trying to fix myself. Issues:
1. volume control on rear of steering wheel will lower volume but not raise it.
2. auto headlights dont work.
3. power wire that attaches to the rear window defogger on drivers side is detached from the window/defogger.

1. Maybe just the control itself? Easy to change? Expensive?

2. I saw on this forum that disconnecting the battery for a few minutes cleared one guys problem with the auto headlights. Sure is simple enough but Im not sure why it would fix the problem? The sensor Im guessing is located on top of the dash? Tough or expensive to change?

3. I could bring the car to a local glass shop and have the connector soldered back on the rear window, shouldnt take too long or cost that much, maybe do it myself?

Thoughts?

Or just hump it to the local dealer which is closer but a real nightmare to deal with or spend a day or so and take it back where we bought it? Certified Jeep by the way, you would think the dealer would have it tottally ready to go.

Hello esu,

I was unable to find any technical service bulletins related to your 3 concerns, but see you've made an appointment with a dealer. Please keep us updated on the diagnosis. I am here if you have any additional questions!
__________________
Andrea
Jeep Social Care Specialist
JeepCares is offline   Reply With Quote Quick reply to this message
Unread 06-30-2015, 12:06 PM   #7
esu
Registered User
1995 ZJ 
 
Join Date: Sep 2012
Location: STATEN ISLAND, ny
Posts: 146
Quote:
Originally Posted by JeepCares View Post
Hello esu,

I was unable to find any technical service bulletins related to your 3 concerns, but see you've made an appointment with a dealer. Please keep us updated on the diagnosis. I am here if you have any additional questions!
I will and thank you, my appt is for 7/7 at Manfredi, unfortunately not my favorite dealer to deal with. I will keep you posted. Are you an official representative of Jeep?
esu is offline   Reply With Quote Quick reply to this message
Unread 06-30-2015, 01:12 PM   #8
JeepCares
FCA Customer Care
 
JeepCares's Avatar
 
Join Date: Jan 2012
Location: MOPAR World Headquarters
Posts: 2,848
Quote:
Originally Posted by esu View Post
I will and thank you, my appt is for 7/7 at Manfredi, unfortunately not my favorite dealer to deal with. I will keep you posted. Are you an official representative of Jeep?
Yes, I am! Thanks for the update
__________________
Andrea
Jeep Social Care Specialist
JeepCares is offline   Reply With Quote Quick reply to this message
Unread 07-01-2015, 08:25 PM   #9
Poncherello
Moderator
2010 KK Liberty 
 
Join Date: Apr 2011
Location: Paterson, New Jersey
Posts: 1,071
Before you purchased the vehicle were these different functions working? Whenever purchasing a used vehicle always let a trusted mechanic unaffiliated with the seller, check it out. If you purchased from a dealer I hope you have some sort of warranty. It sounds like an electrical gremlin. Check to see if the dealer can give you some sort of history on the vehicle, also check car fax. I hope you get the issues resolved very sorry to hear.
__________________
When you get knee-deep in a situation, floor it.
Poncherello is offline   Reply With Quote Quick reply to this message
Unread 07-01-2015, 09:18 PM   #10
TJ's02TJ
Registered User
2012 KK Liberty 
 
Join Date: Nov 2005
Location: Rising Sun, MD
Posts: 89
The cause of my auto headlights not working was a bad sun sensor. I think it was an inexpensive part but I was still under warranty, so not sure.
__________________
2012 KK Liberty. Stock...for now.
TJ's02TJ is offline   Reply With Quote Quick reply to this message
Unread Yesterday, 06:16 AM   #11
esu
Registered User
1995 ZJ 
 
Join Date: Sep 2012
Location: STATEN ISLAND, ny
Posts: 146
Quote:
Originally Posted by Poncherello View Post
Before you purchased the vehicle were these different functions working? Whenever purchasing a used vehicle always let a trusted mechanic unaffiliated with the seller, check it out. If you purchased from a dealer I hope you have some sort of warranty. It sounds like an electrical gremlin. Check to see if the dealer can give you some sort of history on the vehicle, also check car fax. I hope you get the issues resolved very sorry to hear.
Ponch, the car was purchased from a Jeep dealer ( Garden City ) and was "certified" by them. I only noticed the items the day after getting the car home. Tough to check auto headlights in the daytime. I purchased an extended warranty from Jeep since I was past the original 3 yr 36k. I am also under the 30 day 3k warranty for used vehicles. Car fax was clean, one owner, all recalls done and no other issues. My appt is Tuesday, we'll see what happens after that. One other issue that popped up was after I got home we realized that we only had 1 key. I called my salesperson and asked if they could mail me the other key. Turns out they only had one but they cut me a new key and put it in the mail, now I have to get it programmed. Im sure my local dealer is going to be thrilled to program someone elses key and I guess I'll be eating that cost. Oh well, shame on me on that one.
esu is offline   Reply With Quote Quick reply to this message
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.
Note: All free e-mails have been banned due to mis-use. (Yahoo, Gmail, Hotmail, etc.)
Don't have a non-free e-mail address? Click here for a solution: Manual Account Creation
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.


Thread Tools






Jeep, Wrangler, Cherokee, Grand Cherokee, and other models are copyrighted and trademarked to Jeep/Chrysler Corporation. JeepForum.com is not in any way associated with Jeep or the Chrysler Corp.