1 month old '11 in shop already - JeepForum.com
Search  
Sign Up   Today's Posts
User: Pass: Remember?
Advertise Here
Jeep Home Jeep Forum Jeep Classifieds Jeep Registry JeepSpace Jeep Reviews Jeep Gallery Jeep Clubs Jeep Groups Jeep Videos Jeep Events Jeep Articles
Go Back JeepForum.com > Models > Jeep Liberty Forums > KK Liberty Forum > 1 month old '11 in shop already

End of Summer Sale, 20% OFF!2007 - 2011 Jeep JK Long Arm Lift KitsIntroducing MONSTALINER™ UV Permanent DIY Roll On Bed Line

Reply
Unread 04-18-2011, 04:22 PM   #1
Jeepin11
Registered User
2011 KK Liberty 
 
Join Date: Mar 2011
Location: Utica, NY
Posts: 411
1 month old '11 in shop already

So my KK that is one month old with 2013 miles on it is in the shop. It started making a long, loud, clicking noise from the passenger door lock every time the locks engage. I am also having them look at the brakes. I get very inconsistent pedal pressure. Sometimes it is very firm and touchy and other times very soft and un-responsive. And one other thing I noticed was that the coolant reservoir was empty. Call me crazy but I don't think that it should be empty especially being a month old.

__________________
2011 KK- 265/75-16 Wrangler Authorities on 16x8 Racelin Assault wheels
Jeepin11 is offline   Reply With Quote
Unread 04-18-2011, 06:12 PM   #2
Anderson75
Registered User
2010 KK Liberty 
 
Join Date: Apr 2011
Location: Laurel Springs, NJ
Posts: 88
I just purchased a used 2010 Sport that appears to have a leaking rear shock. Hope to get it checked out with the first oil change. At least it's still covered under the BtB warranty.... Good luck.
Anderson75 is offline   Reply With Quote
Unread 04-18-2011, 07:22 PM   #3
slipperybrain
Registered User
2011 KK Liberty 
 
Join Date: Jan 2011
Location: Philly, Pennsylvania
Posts: 57
My 2011 was in the shop the very next day...issue with the drivers side lock. They had to replace the door lock mechanism.
slipperybrain is offline   Reply With Quote
Unread 04-18-2011, 09:52 PM   #4
Nanigai
Registered User
2014 WK 
 
Join Date: Feb 2011
Location: Townsville, Queensland
Posts: 6
I lost coolant through the leak problem in the heater exchanger which blew a seal or some such and the smell of burnt coolant inside the car was horrendous.

Also had a problem with ECU which had to be reset when the rear door lock kept making noises when I opened the drivers door etc. Good luck.

2010 Ltd
Nanigai is offline   Reply With Quote




Jeep, Wrangler, Cherokee, Grand Cherokee, and other models are copyrighted and trademarked to Jeep/Chrysler Corporation. JeepForum.com is not in any way associated with Jeep or the Chrysler Corp.