09 liberty wont rev above 2000 rpm - JeepForum.com
Reply
 
LinkBack Thread Tools
post #1 of 21 Old 07-29-2013, 10:00 AM Thread Starter
kyle0617
Registered User
 
Join Date: Jul 2013
Posts: 9
09 liberty wont rev above 2000 rpm

Seriously need help! I am stationed in Okinawa Japan, my wife and children are back stateside and have a serious issue with her jeep. I am not there to diagnose or fix it myself, I am just wondering is this "limp mode" the way she describes it are as follows: the jeep feels like it is trying to go forward while in park, and then it will not rev above 2000 rpm. From the research I have done I my own I believe I am right with the limp mode thought. Curious if there is an ate home fix I could tell her instead of paying the money to have someone else do it. And yes she is somewhat mechanically inclined and I could probably describe for her how to do it. Thanks for any and all input!

kyle0617 is offline  
Sponsored Links
Advertisement
 
post #2 of 21 Old 07-29-2013, 10:16 AM
_benjammin
Registered User
2012 KK Liberty 
 
Join Date: Mar 2012
Location: Wilmington
Posts: 335
I'm not much help but first thing to try, disconnect battery for a few minutes and reconnect. Where is the Jeep? Maybe someone close could help.
Sorry to hear about your Jeep trouble.
Thank you for your service.
_benjammin is offline  
post #3 of 21 Old 07-29-2013, 10:22 AM Thread Starter
kyle0617
Registered User
 
Join Date: Jul 2013
Posts: 9
The jeep is in Dover, de worst case scenario, ill be heading back for a few days on thurs, I'd just rather her have wheels. Thanks though ill have her try that
kyle0617 is offline  
post #4 of 21 Old 07-29-2013, 02:26 PM
myfirstjeep1
Registered User
 
Join Date: Oct 2011
Location: keyport
Posts: 95
Dover nj?
myfirstjeep1 is offline  
post #5 of 21 Old 07-29-2013, 02:44 PM
Gageraid
Registered User
2008 KK Liberty 
 
Join Date: May 2012
Location: Branchburg
Posts: 1,525
Quote:
Originally Posted by myfirstjeep1 View Post
Dover nj?
x2
Gageraid is offline  
post #6 of 21 Old 07-29-2013, 03:00 PM
LUV4JEEP
Registered User
 
Join Date: Aug 2012
Posts: 84
My jeep is in the dealer right now same issue!!


Right now there saying something with the fuel system but there keeping it overnight to do a cold start ill keep ya poster
LUV4JEEP is offline  
post #7 of 21 Old 07-30-2013, 12:00 AM Thread Starter
kyle0617
Registered User
 
Join Date: Jul 2013
Posts: 9
Dover, Delaware, she actually was just in and around Atlantic city, nj. As of a couple hours ago it fixed itself. She said she went out to give it a try and somehow it acts fine now. I hope the best for your jeep. Hoping mine was just a fluke.
kyle0617 is offline  
post #8 of 21 Old 07-30-2013, 05:04 AM
LUV4JEEP
Registered User
 
Join Date: Aug 2012
Posts: 84
Same thing happened to mine man!! It did the 2,000 rpm thing on Sunday but Yesterday taking it into the dealer it ran fine but while the tech was working on it it happened again for him there doing some cold start tests this am so ill let ya know
LUV4JEEP is offline  
post #9 of 21 Old 07-30-2013, 08:01 AM
LUV4JEEP
Registered User
 
Join Date: Aug 2012
Posts: 84
Update!!

Ok the dealer just called me and said this is normal!!! I can't believe it how is this normal had this car sence it had 10miles on it and it has never done this ! I'm at a loss for words right now nooo clue what to do
LUV4JEEP is offline  
post #10 of 21 Old 07-30-2013, 08:13 AM
huntb
Registered User
2008 KK Liberty 
 
Join Date: Aug 2011
Location: Grand Haven
Posts: 630
Quote:
Originally Posted by LUV4JEEP View Post
Update!!

Ok the dealer just called me and said this is normal!!! I can't believe it how is this normal had this car sence it had 10miles on it and it has never done this ! I'm at a loss for words right now nooo clue what to do
Find a new dealer or call Chrysler and talk to them about it. They can open up a case for you and help you to get it resolved. It is definitely NOT normal. And this is why I hate dealers with a burning passion
huntb is offline  
post #11 of 21 Old 07-30-2013, 08:22 AM
AtTheHelm
Registered User
 
Join Date: Nov 2012
Location: South Lake Tahoe
Posts: 861
When the engine is cold and in neutral or park it won't rev over 2k.
AtTheHelm is offline  
post #12 of 21 Old 07-30-2013, 01:09 PM
LUV4JEEP
Registered User
 
Join Date: Aug 2012
Posts: 84
Quote:
Originally Posted by AtTheHelm
When the engine is cold and in neutral or park it won't rev over 2k.

Helm this has never happened before tho me and my wife both have 09 Libby's mine has never done it
LUV4JEEP is offline  
post #13 of 21 Old 07-30-2013, 02:21 PM
LUV4JEEP
Registered User
 
Join Date: Aug 2012
Posts: 84
And it's July and 83 degrees out
LUV4JEEP is offline  
post #14 of 21 Old 07-30-2013, 02:26 PM
jeepin1995
Registered User
 
jeepin1995's Avatar
1998 TJ Wrangler 
 
Join Date: Sep 2004
Location: wilmington & raleigh
Posts: 1,796
it won't rev over 2K when in neutral or park? or when driving? if when in park, that seems normal. why would you want to rev over 2K when not driving anyways (especially cold). every newer car i have had (Honda civic, Jeep Patriot) have a rev limiter to keep you from revving over a certain RPM to prevent screwing your engine.

"IF YOU CAN'T DAZZLE THEM WITH FACTS, BAFFLE THEM WITH BS"
jeepin1995 is offline  
post #15 of 21 Old 07-30-2013, 02:50 PM
LUV4JEEP
Registered User
 
Join Date: Aug 2012
Posts: 84
Well they changed me $115 dollars had the jeep for over 24 hours made me rent a car for $50 scared me by saying its prolly the fuel system and then I get a call saying "it's normal" and my service guy left early so know one could answer my questions FML
LUV4JEEP is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.



Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome