08 Liberty Rough Idling in "Drive" - JeepForum.com
 
LinkBack Thread Tools
post #1 of 5 Old 08-14-2011, 03:25 AM Thread Starter
Luch466
Registered User
2008 KK Liberty 
 
Join Date: Aug 2011
Location: Maple
Posts: 11
08 Liberty Rough Idling in "Drive"

I've noticed lately that my 08 Jeep Liberty has been rough idling while at a stop sign or intersection. It makes the car vibrate aggressively sometimes and gets really annoying. What is the cause of this rough Idling and how can I fix it?

Luch466 is offline  
Sponsored Links
Advertisement
 
post #2 of 5 Old 08-14-2011, 05:45 PM
SuperRliBerty
Registered User
2008 KK Liberty 
 
Join Date: Jan 2010
Location: Florida
Posts: 1,442
I had cleaned my throttle body and replaced the stock plugs with Bosch Platinums...... rock steady idle in park, reverse or drive.

Try those.

If no CE light, the EGR and it's operation are to be checked.

2008 Sport Liberty
Cold air intake*Trush (magnaflow) turbo muffler* Hypertech power program*
Hood Prop mod. Battery Quick Release mod.
Resonator removed (sounds like a V8 on start up)
SuperRliBerty is offline  
post #3 of 5 Old 08-14-2011, 11:51 PM Thread Starter
Luch466
Registered User
2008 KK Liberty 
 
Join Date: Aug 2011
Location: Maple
Posts: 11
Quote:
Originally Posted by SuperRliBerty View Post
I had cleaned my throttle body and replaced the stock plugs with Bosch Platinums...... rock steady idle in park, reverse or drive.

Try those.

If no CE light, the EGR and it's operation are to be checked.
I am Coming across 2 kinds of Bosch Platinum. There is the Bosh Platinum and then Bosch Plantinum +4. What is the difference?
Luch466 is offline  
post #4 of 5 Old 08-15-2011, 05:21 AM
Elt31987
Senior Member
 
Elt31987's Avatar
2008 KK Liberty 
 
Join Date: Mar 2009
Location: Stoneham, Massachusetts
Posts: 944
Just put in the stock NGK plus, Clean the throttle Body and Injectors, and replace air filter if over 12K with a standard FRAM Double Guard

---------------------------------------------------
2008 KK Liberty
Inferno Red
Daystar 2" Spacer Lift With SkyJacker Hydro Shocks
JBA Gen 5.5 Upper Control Arms
Rokmen Riddler 8.25 Differential Cover
2 KC Slimlite 100 Watt Driving Lights on JK Light Bar
245/75/16 All Terrains
Mopar Front Tow Hooks
Mopar Rear Tow Hook
Mopar Skids
Elt31987 is offline  
post #5 of 5 Old 11-22-2011, 10:58 AM
dtj8995
Registered User
2008 KK Liberty 
 
Join Date: Oct 2011
Location: kalamazoo
Posts: 37
had your same problem...perplexed me...turned out to be the plug coil for my cyl 4 ...25 dollars later and 5 minutes of work my issues was gone...used the same bosch plugs and everything... check the coil
dtj8995 is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.



Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Similar Threads
Thread Thread Starter Jeep Forums Replies Last Post
Help: jeep liberty 2009 8" ROOF antenna NEEDED bobbarto KK Liberty Forum 25 09-09-2011 05:52 AM
Jeep Liberty 3.5" Lift SuperRliBerty KK Liberty Forum 7 02-18-2011 10:56 PM
First Drive: 2011 Jeep Liberty ( Beautiful scenic pics) SuperRliBerty KK Liberty Forum 7 01-20-2011 04:35 PM
What color "white" is my Liberty? DentonTrue KK Liberty Forum 8 11-01-2010 11:42 AM
2010 Liberty "Renegade" with Transmission Vibration davebwi KK Liberty Forum 4 08-09-2010 11:39 AM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome