08 Liberty randomly switches to 4WD - JeepForum.com
Search  
Sign Up   Today's Posts
User: Pass: Remember?
Advertise Here
Jeep Home Jeep Forum Jeep Classifieds Jeep Registry JeepSpace Jeep Reviews Jeep Gallery Jeep Clubs Jeep Groups Jeep Videos Jeep Events Jeep Articles
Go Back JeepForum.com > Models > Jeep Liberty Forums > KK Liberty Forum > 08 Liberty randomly switches to 4WD

Currie Antirock, Currectlync & Lift Kits on Sale!Oconee Off-Road Free Shipping Lifts Tires Bumpers Tops andIntroducing MONSTALINER™ UV Permanent DIY Roll On Bed Line

Reply
Unread 08-31-2013, 04:01 PM   #1
smlkramer
Registered User
 
Join Date: Aug 2013
Location: Cleveland, OH
Posts: 2
08 Liberty randomly switches to 4WD

I have an 08 Liberty Sport that keeps switching to 4WD on its own. For example, today I was waiting with the vehicle on and in park and I heard a 'ding' and the 4WD lo light was on. If I move the 4WD switch the light won't turn off. I turned the Jeep off and on a few times and the LO light went off but it remained in 4WD. About 2 weeks ago this happened and I took it to an auto parts store to have its codes read. I got: C121C and P0513. When researching the codes, I came up with something to have to do with a remote start incompatibility (dealer installed) and a crankshaft sensor failure. I replaced the crankshaft sensor. Upon start up after replacing the sensor, I heard an audible click and it was no longer in 4WD. When attempting to move the 4WD switch, it does not work. If it is or isn't in 4WD the switch does nothing. Now it's back in 4WD today. 2 ideas I have: #1 - my son hit the remote start button. Last time this happened, it seems to maybe be a coincidence or not, but this happened with the 4WD getting stuck on. Does anyone think it's the remote start at all? Sounds ridiculous, I know. Never had an issue with it. Ok, idea #2, I got 2 flat tires in the same day a few months ago and had to have them replaced. I did not have the tire pressure sensors replaced on the new tires and I had rubber valve stems put on them. Does anyone think this may be the problem? Thanks for all of your help and suggestions!!

smlkramer is offline   Reply With Quote Quick reply to this message
Unread 08-31-2013, 05:18 PM   #2
lfhoward
Registered User
2008 KK Liberty 
 
Join Date: Nov 2012
Location: Ann Arbor, MI
Posts: 523
I wonder if your four wheel drive switch is shorting. You can pull up that trim piece on your center console, then unplug the 4WD switch pigtail and clean the connections, then reinstall. I'd start there and see if that fixes it. The problem sounds super inconvenient! Make sure not to drive on pavement in 4WD (unless you have the select trac option), or you can mess up your transfer case.
__________________
2008 Liberty Sport 4x4 Automatic
lfhoward is offline   Reply With Quote Quick reply to this message
Unread 08-31-2013, 05:20 PM   #3
lfhoward
Registered User
2008 KK Liberty 
 
Join Date: Nov 2012
Location: Ann Arbor, MI
Posts: 523
I think the remote start and the TPMS were just coincidence.
__________________
2008 Liberty Sport 4x4 Automatic
lfhoward is offline   Reply With Quote Quick reply to this message
Unread 08-31-2013, 07:13 PM   #4
smlkramer
Registered User
 
Join Date: Aug 2013
Location: Cleveland, OH
Posts: 2
Thank you! Yes, I find it odd I can switch the the switch back and forth and it does absolutely nothing. I will try that in the morning and let you know. Thanks!
smlkramer is offline   Reply With Quote Quick reply to this message
Unread 08-31-2013, 08:53 PM   #5
AtTheHelm
Registered User
 
Join Date: Nov 2012
Location: South Lake Tahoe, CA
Posts: 762
Check the other side ofthe connection too at the t case
AtTheHelm is offline   Reply With Quote Quick reply to this message
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.
Note: All free e-mails have been banned due to mis-use. (Yahoo, Gmail, Hotmail, etc.)
Don't have a non-free e-mail address? Click here for a solution: Manual Account Creation
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.


Thread Tools






Jeep, Wrangler, Cherokee, Grand Cherokee, and other models are copyrighted and trademarked to Jeep/Chrysler Corporation. JeepForum.com is not in any way associated with Jeep or the Chrysler Corp.