JeepForum.com

JeepForum.com (http://www.jeepforum.com/forum/)
-   KK Liberty Forum (http://www.jeepforum.com/forum/f292/)
-   -   08 Liberty Blinking Red voltage icon (http://www.jeepforum.com/forum/f292/08-liberty-blinking-red-voltage-icon-1518046/)

showstoppr88 05-02-2013 11:46 PM

08 Liberty Blinking Red voltage icon
 
Hey all I have an 08 Liberty and just got this blinking red light looks like " |Z| ". I hear its the elec throttle control warning light. Makes sense cause when it comes on the car accelerates funny. Only comes on now and an again turn off the car and its fixed for a a while (one of those). So anyway take it to autozone, no codes and battery is perfect. Any ideas on what the issue might be?

BettyHumpter 05-10-2013 06:55 AM

Bad connection at the throttle body? Bad sending unit at the accelerator?

showstoppr88 05-13-2013 03:23 PM

Funny thing is I get this alot when stopped then after that it starts to accelerate weird. I think I am stuck having to to go the dealer cause I swapped out the throttle body assem and no luck.

Gageraid 05-13-2013 07:49 PM

Sounds pretty scary. Keep us posted.

showstoppr88 05-15-2013 07:28 PM

It's at the dealer now they replaced the pedal drove half down the road and did it again still at the dealer they said maybe the PCM ...ugh find out tomorrow, any clue what that might cost? I'm afraid honestly.

JeepCares 05-16-2013 12:35 PM

I'm not technical, but many others here are. I know you said you don't have any codes, but I found this STAR Case (ignore if not applicable):

STAR Case Number: S1208000016
Release Date: 1/19/2012
Symptom/Vehicle Issue:
MIL P0122, P0123, P0124, P2121, P2122, P2123, P2127 and/or P2128 present. The Accelerator Pedal Sensor (APPS) may have been replaced previously.
Discussion:
Replacing the APPS and not finding the “Root Cause” may result in a repeat failure. Check the APP Sensor operation using a scan tool and monitor the APP sensor #1 and #2 while slowly actuating the accelerator pedal from full up to full down position. APP Sensor #1 should start at approximately 0.45 volts and go above 4.6 volts with a smooth and stable signal with no dropouts and is repeatable.
APP Sensor #2 signal should be approximately (50%) the voltage shown in the APP Sensor #1 with a smooth and stable signal with no dropouts and again, it should be repeatable. If the both signals are acceptable as described above, most likely a circuit wiring and/or connector(s) may have an issue. Previous terminal investigation / diagnostics without the use of a proper PCM PINOUT BOX can lead to loose pins and intermittent connections. Dirty, and/or contaminated connectors are also suspect of intermittent connections. Inspect for aftermarket components installed in the interior and under hood to review if any wiring has been moved, spliced or modified. Look for frayed, cut, nicked, split wiring, loose and/or damaged terminals.
Diagnosis:
If the vehicle comes in with the DTC(s) stored, it is usually an intermittent connection. Record the DTC(s). Turn engine off and then turn key ON (engine off) and locate the in line connector (see table on page 2), grab the wiring bundle on both sides of the connector and wiggle wiring. If the DTC becomes active, your issue is in the associated connector / wiring harness area. If DTC does not become active move to the engine powertrain control module (PCM) harness / connectors C1, C2, C3 and grab those wiring harnesses and wiggle them to see if the code become active. In addition, do the same test to the wiring harness connector at the accelerator pedal connector.
If the DTC becomes active, your issue is in that associated connector/wiring harness area.
If the customer complaints of the lightning bolt lamp on the dashboard being lit and then going off inquire about where the customer was driving the vehicle. Rough, coarse, pitted, pot holed roads, and/or railroad crossings can increase the effects of an intermittent connection.

Vehicles KK, KA
Model Years 2008-2012
Powertrain Control Module Connectors C1, C2, C3
Inline Connector C202
Accel Pedal Connector D1563

showstoppr88 05-18-2013 04:57 PM

Replaced PCM and they say "its done"....its not made it happen before I left the lot! Ugh frustrating, they are taking care of me though so thats appreciated I am 6K miles out of my power train warranty and they are doing it under warranty and giving me a rental car on their dime. They are now thinking the harness (which I said I thought was the issue when I brought it in ;) )

Keep you posted.

Oh BTW..... a new PCM $900 if anyone was wondering.

Makes me feel like if the next step doesnt work its never gonna be fixed though I just bought this car last year so its not like I can just up and get a new car :/


The time now is 12:51 PM.

Powered by vBulletin Version 3.8.4
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.