JeepForum.com

JeepForum.com (http://www.jeepforum.com/forum/)
-   Jeep Liberty Forums (http://www.jeepforum.com/forum/f291/)
-   -   Condensor problems??? Please help!!! (http://www.jeepforum.com/forum/f291/condensor-problems-please-help-1386116/)

dm4gators 06-26-2012 08:37 PM

Condensor problems??? Please help!!!
 
My AC in my 2005 Jeep Liberty stopped working 3 weeks ago. Since then I added refrigerant and it seemed to work well. Today while I was at a red light, it stopped blowing cold (still blew hot) and when I stepped on the gas it got ice cold again. Is this the condensor? It only does this when the vehicle is not moving. If so, how hard is it to replace? Any advise on where online to get one from? Any tricks or must knows? TYVM!!!!

dcowans 02-10-2015 09:27 AM

Check your fan

streetglideok 04-09-2015 01:08 PM

Yep check the fan. Should be a two speed fan, and you likely lost the low speed. When you Rev it up, it may build enough pressure to force the high speed on. Do not, repeat do not waste your money on a Dorman unit.

Sparky1234 05-27-2015 05:07 PM

I would recommend checking the high cap (idk if that's the official name of it). Basically, the cap all the way to the left in the engine compartment that you use when adding coolant.

Crank the car, turn the AC on full, then check to see if any coolant is leaking out of that area. There is a stem in it that can sometimes come loose or allow it to leak--this was the case with mine AFTER I had the air compressor replaced because it too did not work.

It's a quick fix if that's the problem, hopefully it's not your compressor. Good luck!


The time now is 02:27 AM.

Powered by vBulletin Version 3.8.4
Copyright ©2000 - 2015, Jelsoft Enterprises Ltd.