Xcase position sensor causing the speedo to short? - JeepForum.com
Search  
Sign Up   Today's Posts
User: Pass: Remember?
Advertise Here
Jeep Home Jeep Forum Jeep Classifieds Jeep Registry JeepSpace Jeep Reviews Jeep Gallery Jeep Clubs Jeep Groups Jeep Videos Jeep Events Jeep Articles
Go Back JeepForum.com > Models > Jeep Liberty Forums > KJ Liberty Forum > Xcase position sensor causing the speedo to short?

FS: 2007-2013 Jeep Wrangler "HALO" Angel Eye KitFlowmaster's Force II Axle-back exhaust system for the 201FS: Wranger BRIGHT License Plate LED! Just $3! Great value

Reply
Unread 05-22-2013, 01:15 PM   #1
SCACExOFxSPADES
Registered User
2004 KJ Liberty 
 
Join Date: Apr 2013
Location: Pittsfield, MA
Posts: 6
Xcase position sensor causing the speedo to short?

Can a corroded transfercase position sensor clip and sensor housing (I know I have to change it soon) cause the speedometer to short and burn out? I've got an '04 Liberty 3.7 and in less than a month (without driving it on the road more than 2 laps around the block), I've replaced and apparently burned through a speedo from an '06 Liberty of the same type. It was working perfectly before that. I just can't figure out what's causing it to fry. The speedo needle jumps around like its a bad PCM, but I checked it all, and it seems fine. No frays, no burns, nothing. It was running smooth until it was put into drive today, which it stalled out and gave me the same issues as it had when I bought it. I know it's got to be the sensors on either the Xcase, rear diff, or Xmission, but I can't figure out which it would cause to blow that damn thing.

Pictures of the wires for the Xcase are below.

Any ideas?

photo-8-.jpg   photo-7-.jpg  
SCACExOFxSPADES is offline   Reply With Quote
Unread 05-22-2013, 02:12 PM   #2
tommudd
Registered User
2004 KJ Liberty 
 
Join Date: Aug 2008
Location: Central OH/ Moshi Tanzania, Ohio/Tanzania
Posts: 4,105
04s get the speed signal from the rear diff, have you checked the plug etc on the diff. They get corroded and will cause speedo issues
__________________
04 Liberty, Kilimanjaro Edition, Rock Lizard RockRails/Roof Rack/Front-Rear bumper,32 inch Goodyear Duratracs,Moabs,4.10s/ 4.25 inch JBA Coilover lift /other goodies
tommudd is online now   Reply With Quote
Unread 05-22-2013, 04:03 PM   #3
SCACExOFxSPADES
Registered User
2004 KJ Liberty 
 
Join Date: Apr 2013
Location: Pittsfield, MA
Posts: 6
Quote:
Originally Posted by tommudd
04s get the speed signal from the rear diff, have you checked the plug etc on the diff. They get corroded and will cause speedo issues
Haven't checked that. Could that really cause it to burn out? Ill be looking at that tomorrow.
SCACExOFxSPADES is offline   Reply With Quote




Jeep, Wrangler, Cherokee, Grand Cherokee, and other models are copyrighted and trademarked to Jeep/Chrysler Corporation. JeepForum.com is not in any way associated with Jeep or the Chrysler Corp.