JeepForum.com

JeepForum.com (http://www.jeepforum.com/forum/)
-   KJ Liberty Forum (http://www.jeepforum.com/forum/f28/)
-   -   Xcase position sensor causing the speedo to short? (http://www.jeepforum.com/forum/f28/xcase-position-sensor-causing-speedo-short-1526865/)

SCACExOFxSPADES 05-22-2013 01:15 PM

Xcase position sensor causing the speedo to short?
 
2 Attachment(s)
Can a corroded transfercase position sensor clip and sensor housing (I know I have to change it soon) cause the speedometer to short and burn out? I've got an '04 Liberty 3.7 and in less than a month (without driving it on the road more than 2 laps around the block), I've replaced and apparently burned through a speedo from an '06 Liberty of the same type. It was working perfectly before that. I just can't figure out what's causing it to fry. The speedo needle jumps around like its a bad PCM, but I checked it all, and it seems fine. No frays, no burns, nothing. It was running smooth until it was put into drive today, which it stalled out and gave me the same issues as it had when I bought it. I know it's got to be the sensors on either the Xcase, rear diff, or Xmission, but I can't figure out which it would cause to blow that damn thing.

Pictures of the wires for the Xcase are below.

Any ideas?

tommudd 05-22-2013 02:12 PM

04s get the speed signal from the rear diff, have you checked the plug etc on the diff. They get corroded and will cause speedo issues

SCACExOFxSPADES 05-22-2013 04:03 PM

Quote:

Originally Posted by tommudd
04s get the speed signal from the rear diff, have you checked the plug etc on the diff. They get corroded and will cause speedo issues

Haven't checked that. Could that really cause it to burn out? Ill be looking at that tomorrow.


The time now is 07:20 AM.

Powered by vBulletin Version 3.8.4
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.