Weird problem with Lift Glass and Rear wiper motor... - JeepForum.com

 
LinkBack Thread Tools
post #1 of 7 Old 07-11-2011, 07:58 AM Thread Starter
phorty
Registered User
 
Join Date: Mar 2007
Location: Chicagoland
Posts: 25
Weird problem with Lift Glass and Rear wiper motor...

So the rear wiper stopped working on my wife's 2003 Liberty last winter, got stuck halfway on the window. I recently got an used OEM wiper motor and replaced it. When I tried the rear wiper, all I hear is a click, like the motor is turning on but nothing happens. Then nothing happens at all, no response from the motor, no click if I turn it on again. If I try it the next day, it will click again and then be non-responsive. So I figured either the used motor was bad or I have other issues and perhaps the old motor wasn't bad in the first place.

Here is where things got weird. My wife tells me she went somewhere, locked the doors with the key fob, then as she was walking away, the alarm started going off. And then we notice the interior lights are on all the time and the dash says the rear lift glass is open. I can open and close it and it still thinks it's open. What is going on here, did I screw up some electrical when I replaced the motor? The install was very straightforward- unplug 3 connectors, 2 or 3 nuts and done...


Wife's "New" Car- '06 Commander Limited 4.7L- 95k
Wife's "Old" Car- '03 Liberty Limited- 151k
'97 Dodge Ram 1500 4x4
'06 Mustang GT Windveil Blue- Borla Stingers, MGW Shifter, Intake/Tune, GT500 wheels/tires
'93 Mustang LX Notch- 144k, Saleen Speedline Wheels
phorty is offline  
Sponsored Links
Advertisement
 
post #2 of 7 Old 07-11-2011, 12:07 PM
Billwill
Registered User
2002 KJ Liberty 
 
Join Date: Jul 2007
Location: Hoedspruit, in the Bush, South Africa
Posts: 1,311
Quote:
Originally Posted by phorty View Post
So the rear wiper stopped working on my wife's 2003 Liberty last winter, got stuck halfway on the window. I recently got an used OEM wiper motor and replaced it. When I tried the rear wiper, all I hear is a click, like the motor is turning on but nothing happens. Then nothing happens at all, no response from the motor, no click if I turn it on again. If I try it the next day, it will click again and then be non-responsive. So I figured either the used motor was bad or I have other issues and perhaps the old motor wasn't bad in the first place.

Here is where things got weird. My wife tells me she went somewhere, locked the doors with the key fob, then as she was walking away, the alarm started going off. And then we notice the interior lights are on all the time and the dash says the rear lift glass is open. I can open and close it and it still thinks it's open. What is going on here, did I screw up some electrical when I replaced the motor? The install was very straightforward- unplug 3 connectors, 2 or 3 nuts and done...
If you do a search on this Forum for "Liberty Service Manuals" you will find a link to all the manuals for the 2002/2003 Liberties..gas or diesel, USA or Export.
Download Section 8, Electrical Diagrams (about 42 Mb) It not only gives you all the circuit diagrams but also the theory on how..for instance...the rear wiper and rear glass mechanisms work as well as locations of components.
There is a switch that senses that the glass is closed...yours may need adjustment as the BCM is not sensing it is closed...probably why the wiper is not working as well..it will not run if the glass is supposedly open!
Billwill is offline  
post #3 of 7 Old 07-11-2011, 01:13 PM Thread Starter
phorty
Registered User
 
Join Date: Mar 2007
Location: Chicagoland
Posts: 25
Ahh, that makes sense! I must done something during the motor install to through off the sensor. I did not put the plastic panel back on yet, maybe that is involved. Hopefully, I don't have to dive too deeply into the circuit diagrams as I am electronically challenged!!

Wife's "New" Car- '06 Commander Limited 4.7L- 95k
Wife's "Old" Car- '03 Liberty Limited- 151k
'97 Dodge Ram 1500 4x4
'06 Mustang GT Windveil Blue- Borla Stingers, MGW Shifter, Intake/Tune, GT500 wheels/tires
'93 Mustang LX Notch- 144k, Saleen Speedline Wheels
phorty is offline  
post #4 of 7 Old 07-13-2011, 04:00 PM
AndyTee
Registered User
2002 KJ Liberty 
 
Join Date: Oct 2010
Location: Aberdeen Scotland UK
Posts: 99
Quote:
Originally Posted by phorty View Post
Ahh, that makes sense! I must done something during the motor install to through off the sensor. I did not put the plastic panel back on yet, maybe that is involved. Hopefully, I don't have to dive too deeply into the circuit diagrams as I am electronically challenged!!
Your inbox is full so here is my reply by the way:-)

Hi John,
there is a microswitch in the glass latch mechanism which is "open circuit" when the door is closed and a "closed circuit" with the glass open. AS I didn't have a spare switch and my nearest Jeep dealer is a long way away I just diconected the wiring to the door latch switch and it sees it as open circuit which indicates the glass is closed. I have never bothered to buy a new switch as everything is fine and I just make sure the glass is fully closed each time I use the tailgate.
To get to the switch you have to remove the tailgate inside cover which from memory was very simple.
You can't get into the switch to repair it as its a magnetic switch but you could try checking there is no dirt in there stopping it from working properly.
Good luck. Oh and by teh way, if you disconnect the switch wiring and you still have the glass indication up it maybe your multifunction switch on the indicator stems as they can go apparently.

regards

Andy
AndyTee is offline  
post #5 of 7 Old 07-13-2011, 06:49 PM Thread Starter
phorty
Registered User
 
Join Date: Mar 2007
Location: Chicagoland
Posts: 25
Thanks for the message Andy. Just cleaned out the inbox!

I actually had the inside cover off already from doing the wiper motor install. I monkeyed with it for the last half hour- both sensor plugs connected, one connected and the other disconnected, vice versa, and both totally unplugged. Nothing I could do fooled the car into thinking the tailgate was closed! The interior light stays on unless I manually turn it off. And alarm think I left it open.

Could that sensor be seized in the "Closed Circuit"? Could have done that somehow by doing the wiper motor install?

Wife's "New" Car- '06 Commander Limited 4.7L- 95k
Wife's "Old" Car- '03 Liberty Limited- 151k
'97 Dodge Ram 1500 4x4
'06 Mustang GT Windveil Blue- Borla Stingers, MGW Shifter, Intake/Tune, GT500 wheels/tires
'93 Mustang LX Notch- 144k, Saleen Speedline Wheels
phorty is offline  
post #6 of 7 Old 07-14-2011, 09:35 AM Thread Starter
phorty
Registered User
 
Join Date: Mar 2007
Location: Chicagoland
Posts: 25
I want to try and fix this soon so I think I'll just replace the switch. Does anyone know the part number? Not sure if the dealer will know what I'm talking about.

Wife's "New" Car- '06 Commander Limited 4.7L- 95k
Wife's "Old" Car- '03 Liberty Limited- 151k
'97 Dodge Ram 1500 4x4
'06 Mustang GT Windveil Blue- Borla Stingers, MGW Shifter, Intake/Tune, GT500 wheels/tires
'93 Mustang LX Notch- 144k, Saleen Speedline Wheels
phorty is offline  
post #7 of 7 Old 07-16-2011, 09:32 PM Thread Starter
phorty
Registered User
 
Join Date: Mar 2007
Location: Chicagoland
Posts: 25
So I worked backwards and put the original non-functioning rear wiper motor back in and the problem went away. Not sure what was going on with the new motor.

Wife's "New" Car- '06 Commander Limited 4.7L- 95k
Wife's "Old" Car- '03 Liberty Limited- 151k
'97 Dodge Ram 1500 4x4
'06 Mustang GT Windveil Blue- Borla Stingers, MGW Shifter, Intake/Tune, GT500 wheels/tires
'93 Mustang LX Notch- 144k, Saleen Speedline Wheels
phorty is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.



Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Similar Threads
Thread Thread Starter Jeep Forums Replies Last Post
Rear Glass bnrboy775 KJ Liberty Forum 7 10-10-2010 06:22 AM
How do you replace the Jeep Liberty 03 Rear Window Glass Lift Supports? kevmolab KJ Liberty Forum 1 09-12-2010 08:24 PM
rear glass light goyle73 KJ Liberty Forum 1 08-12-2010 05:17 AM
Rear wiper problem 03 liberty? apik1 KJ Liberty Forum 1 03-09-2008 04:45 AM
Rear Flip Glass JeepLibertyNYC KJ Liberty Forum 9 05-18-2002 07:00 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome