Washer Fluid & Rear Wiper not working - JeepForum.com

 
LinkBack Thread Tools
post #1 of 8 Old 01-01-2009, 08:12 AM Thread Starter
Glenwood1991
Registered User
2007 KJ Liberty 
 
Join Date: Jan 2009
Location: NJ
Posts: 1
Washer Fluid & Rear Wiper not working

2007 Jeep Liberty - Rear wiper and washer does not work. The fuse for the rear wiper is good. Is there something else I should be checking?

Glenwood1991 is offline  
Sponsored Links
Advertisement
 
post #2 of 8 Old 01-01-2009, 08:31 AM
jeeprscreeprs04
Registered User
2004 KJ Liberty 
 
Join Date: Dec 2008
Location: Michigan
Posts: 5
My 04 just quit working one day out of the blue too. I have no idea but am curious as to what it could be.
jeeprscreeprs04 is offline  
post #3 of 8 Old 01-01-2009, 05:36 PM
STSMWR
Registered User
2003 KJ Liberty 
 
Join Date: Dec 2008
Location: ct
Posts: 11
My rear wiper doesn't work either (03 Liberty) and I paid $85 for an estimate of $385 to replace the rear wiper motor. I can live without it.
STSMWR is offline  
post #4 of 8 Old 05-14-2011, 03:01 PM
craigarbo
Registered User
 
Join Date: May 2011
Location: Brimfield
Posts: 3
Any updates?

My jeep has the exact same problem. Has anyone found a solution for this?
craigarbo is offline  
post #5 of 8 Old 05-15-2011, 02:48 AM
Billwill
Registered User
2002 KJ Liberty 
 
Join Date: Jul 2007
Location: Hoedspruit, in the Bush, South Africa
Posts: 1,326
Does the washer motor make a noise when you operate the switch to clean the rear window?
The washer container has the washer motor inbedded in it, the motor rotates in one direction to direct water to the front screen if you are trying to clean the front and the motor runs in the opposite direction to clean the back...a system of valves directs the water to the correct area.
If the washer motor is dead and the rear wiper does not attempt to move when attempting to wash the rear window...I would suspect that the wiper stalk switch is faulty. I will look at my 2002 circuit diagram...should be close enough to the 2007 model....and see if I can think of anything else!
Billwill is offline  
post #6 of 8 Old 05-26-2011, 07:14 AM
craigarbo
Registered User
 
Join Date: May 2011
Location: Brimfield
Posts: 3
Washer Fluid & Rear Wiper not working

The rear wiper makes no noise at all. The fronts work fine except for when I pull the wiper arm toward myself, no fluid sprays and the wipers don't turn on either. This has got me really confused. I shot the wires back to the rear wiper and it seems to be getting power - 12V.
craigarbo is offline  
post #7 of 8 Old 05-26-2011, 11:35 AM
Billwill
Registered User
2002 KJ Liberty 
 
Join Date: Jul 2007
Location: Hoedspruit, in the Bush, South Africa
Posts: 1,326
Quote:
Originally Posted by craigarbo View Post
The rear wiper makes no noise at all. The fronts work fine except for when I pull the wiper arm toward myself, no fluid sprays and the wipers don't turn on either. This has got me really confused. I shot the wires back to the rear wiper and it seems to be getting power - 12V.
What year model is your KJ?
Does the spray work on either front or back or not at all?

Edit to add: For multiple wiper/washer problems I would suspect first the Multifunction Switch on top of the steering column and then a problem in the BCM which drives most of the wiper functions! Obvioulsly check all fuses and swap over/replace the wiper relays.
Billwill is offline  
post #8 of 8 Old 06-01-2011, 10:46 AM
craigarbo
Registered User
 
Join Date: May 2011
Location: Brimfield
Posts: 3
Neither the front or the rear work. The Jeep is a 2005 Liberty.
craigarbo is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.



Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Similar Threads
Thread Thread Starter Jeep Forums Replies Last Post
windshield washer not working peg KJ Liberty Forum 22 02-22-2016 09:20 AM
Self filling washer fluid??????? Mr_Harry KJ Liberty Forum 10 08-08-2009 07:08 PM
Windshield washer fluid problem terrysliberty KJ Liberty Forum 3 11-14-2006 01:22 PM
Windshield Washer Fluid Squirter RebelsPlaya069 KJ Liberty Forum 0 02-18-2005 03:51 PM
Rear window washer not working moopa KJ Liberty Forum 6 03-07-2004 11:27 AM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome