Transmission Problems! - JeepForum.com
 
LinkBack Thread Tools
post #1 of 3 Old 03-19-2012, 02:16 PM Thread Starter
wmcreyno
Registered User
2002 KJ Liberty 
 
Join Date: Mar 2012
Location: Rockville
Posts: 6
Transmission Problems!

Hey guys im having serious transmission issues. I have a 2002 with a 3.7 and a 45RFE my KJ has 95,000 miles on the odometer. Yesterday i was driving the jeep was behaving normally. i was coming down a very steep grade so i cut of overdrive to have the engine keep the jeep from pickin up speed. About 10 minutes later im driving along and the jeep starts jerking. When the jerk happens it sounds and feels as if the torque converter is locking unlocking. The next part scared the doo doo out of me. When the transmission has no load on it and is coasting or braking i get a horrible grinding sound and jerkiness. If i apply slight throttle while braking the grinding doesn't happen basically if you keep a load on the transmission at all times it will not do this grinding thing. It seems to be shifting normally. The only other thing i noticed was that when i stopped for gas it didn't go into park normally the car rolled a few feet and a few seconds later it went into park. i parked it and don't plan on driving it until i can resolve the issue. The transmission has been serviced normally and i checked the fluid level and it is at the normal level. Also now whenever i try to put it in any gear or shift from neutral to park it grinds and won't go into gear. I can shift to park only with the engine cut off.

Does anyone have any ideas on what the problem may be?

wmcreyno is offline  
Sponsored Links
Advertisement
 
post #2 of 3 Old 03-19-2012, 09:51 PM
3Wide
Registered User
2004 KJ Liberty 
 
Join Date: Feb 2010
Location: Yorkville
Posts: 79
Sounds like major transmission failure, I had a similar problem at 128K my trans blew, had a loud bang from the trans while driving, then nothing just grinding noise.
3Wide is offline  
post #3 of 3 Old 03-20-2012, 08:50 PM Thread Starter
wmcreyno
Registered User
2002 KJ Liberty 
 
Join Date: Mar 2012
Location: Rockville
Posts: 6
narrowed it down to the Transfer case.... there is something screwy with the T-CASE i can put it in 4wd-LOW and it drives and shifts properly... the grinding is actually coming from the T-CASE when i engage the transmission in 2wd and 4WD-high
wmcreyno is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.



Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Similar Threads
Thread Thread Starter Jeep Forums Replies Last Post
Transmission Problems pager KJ Liberty Forum 0 05-01-2009 09:58 AM
Problems with Transmission kglancy KJ Liberty Forum 1 07-13-2007 04:15 PM
Transmission Problems??? penjim KJ Liberty Forum 5 02-18-2005 03:52 PM
Transmission Problems papanator KJ Liberty Forum 0 07-27-2004 01:29 PM
Transmission Problems...Tell me what you think of this!! Tim Paturi KJ Liberty Forum 6 08-22-2002 01:54 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome