Problem with heater -

LinkBack Thread Tools
post #1 of 1 Old 10-28-2013, 02:59 AM Thread Starter
Registered User
Join Date: Oct 2013
Location: VT
Posts: 1
Problem with heater

I have a problem on a 2003 V6 Liberty 4x4...There is only heat on the passenger side! The vehicle does not have dual-zone climate control. Initially we had no heat at all. I drilled a hole into the pivot for the hot / cold blend door, and got the actuator to free up. So now there is heat when you turn the dial to hot, but only on the passenger side!

Any thoughts?

troverman is offline  

Quick Reply

Register Now

In order to be able to post messages on the forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.

Email Address:


Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome