Possibly a low idle? 2005 Jeep Liberty Renegade - JeepForum.com

 
LinkBack Thread Tools
post #1 of 3 Old 04-09-2013, 11:09 PM Thread Starter
shaneybrainy13
Registered User
2005 KJ Liberty 
 
Join Date: Apr 2013
Location: Albuquerque
Posts: 2
Possibly a low idle? 2005 Jeep Liberty Renegade

I have a 2005 Jeep Liberty Renegade (3.7L V6, 6-Speed Manual transmission) that idles a little "rough" I guess you could say. The tach reads roughly 500 to 515 RPM in park with the transmission in neutral (and first as well when not moving) the stick shift shakes about a bit and there is noticeable vibrations (if you look carefully the passenger seat shakes ever so slightly when no one is sitting in it) there are no engine warning lights nor any warning light at all lit up on the dash aside from a "part time" light which I believe to be an unrelated issue (transmission sensor is flipped). Anyway, is a 500 to 520ish idle normal for Jeep Liberties? Or is this idle to low? Sometimes if I rev the engine a little bit in neutral, the needle will dip ever so lightly below the 500RPM mark and you can hear/ feel the engine beginning to choke, the needle then abruptly bounces back up to the 500-520ish mark. Otherwise, the car runs fine. It never shuts off while its idling. The Jeep has 75,000 miles on it. Any help would be appreciated, thanks!


Yeah, I own a Liberty. Yes, it's stock. Yes, it's engine only produces 210 horsepower, but don't underestimate it. You'll be surprised what it can do.
shaneybrainy13 is offline  
Sponsored Links
Advertisement
 
post #2 of 3 Old 04-10-2013, 07:38 AM
x99j
Registered User
 
Join Date: Jan 2005
Location: ohio
Posts: 450
if your throttle body is clean, you spark plugs are newer and stock, and your valves are holding compression it is normal. see the link below. as for the low idle at 500 rpm: i had my pcm reflashed under warranty which raised the idle slightly. mike

http://www.jeepforum.com/forum/f28/3...-rough-504767/

06 kj 3.7l, 6speed manual, np241 command track

91 yj 2.5l, ax-5, np 231 3 inck lift, 31'' mud rovers

12 kk 3.7L, 42rle, mp1522, d-30, 8.25.
x99j is offline  
post #3 of 3 Old 04-10-2013, 06:25 PM
blakeKJ
Registered User
2006 KJ Liberty 
 
Join Date: Aug 2011
Location: barrie
Posts: 28
This happened to me. 06 v6 6 SPD
Except sometimes it stalled and the idle would jump.

I had an injection service (they flush the system and you burn a tank of premium fuel) fixed it right up. Idles perfect.

My 2 cents
blakeKJ is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.



Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome