OTIS Install...HELP - JeepForum.com

 
LinkBack Thread Tools
post #1 of 7 Old 06-12-2014, 11:54 PM Thread Starter
jnasty
Registered User
2004 TJ Wrangler 
 
Join Date: Oct 2013
Location: Muskegon
Posts: 14
OTIS Install...HELP

On my 2004 KJ i recently installed a OTIS overhead console. i followed a very popular instruction manual for installing it and everything works but my temperature reading, it just reads "--" There was already a Ambient air temp sensor installed in the jeep before i did the OTIS install. Just to make sure i went out and bought another Ambient air temp sensor and it's still reading "--"

Some opinions or ideas on how to make it work would be awesome!

jnasty is offline  
Sponsored Links
Advertisement
 
post #2 of 7 Old 06-13-2014, 08:58 AM
02jeepliberty
Registered User
 
Join Date: Jun 2013
Posts: 684
I disconnected the battery for a few minutes to reset everything. Seemed to work fine for me. Good luck, let me know if that helps
02jeepliberty is offline  
post #3 of 7 Old 06-13-2014, 12:41 PM Thread Starter
jnasty
Registered User
2004 TJ Wrangler 
 
Join Date: Oct 2013
Location: Muskegon
Posts: 14
That did not work, i'm wondering if it's something to do with the OTIS module itself? or something else
jnasty is offline  
post #4 of 7 Old 06-14-2014, 01:01 AM
02jeepliberty
Registered User
 
Join Date: Jun 2013
Posts: 684
Quote:
Originally Posted by jnasty
That did not work, i'm wondering if it's something to do with the OTIS module itself? or something else
Could be, there's only one way to find out lol also make sure your OTIS is even compatible. What year car did your Otis come off of? Certain ones only work on certain vehicles
02jeepliberty is offline  
post #5 of 7 Old 06-14-2014, 01:01 AM
02jeepliberty
Registered User
 
Join Date: Jun 2013
Posts: 684
I believe you have to have an Otis from a 2004 since you have a 2004 KJ
02jeepliberty is offline  
post #6 of 7 Old 06-22-2014, 11:32 PM Thread Starter
jnasty
Registered User
2004 TJ Wrangler 
 
Join Date: Oct 2013
Location: Muskegon
Posts: 14
My original OTIS came out of a 2003 KJ, so i went out this weekend and got one out of a 2004 KJ and it works!!!!!! Thanks for all of the suggestions!
jnasty is offline  
post #7 of 7 Old 06-23-2014, 06:57 AM
02jeepliberty
Registered User
 
Join Date: Jun 2013
Posts: 684
Quote:
Originally Posted by jnasty
My original OTIS came out of a 2003 KJ, so i went out this weekend and got one out of a 2004 KJ and it works!!!!!! Thanks for all of the suggestions!
That's great, glad you got it working!
02jeepliberty is offline  
Reply

Tags
liberty , overhead console , temp sensor

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.



Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome