Noise - JeepForum.com
Search  
Sign Up   Today's Posts
User: Pass: Remember?
Advertise Here
Jeep Home Jeep Forum Jeep Classifieds Jeep Registry JeepSpace Jeep Reviews Jeep Gallery Jeep Clubs Jeep Groups Jeep Videos Jeep Events Jeep Articles
Go Back JeepForum.com > Models > Jeep Liberty Forums > KJ Liberty Forum > Noise

Introducing MONSTALINER™ UV Permanent DIY Roll On Bed LineBill Baird Motorsports DIY parts - NalinMFG.comComponent speaker deal for your dash - NalinMFG

Reply
Unread 07-09-2012, 10:59 AM   #1
mrny
Registered User
 
Join Date: Jul 2012
Location: Kalamazoo, mi
Posts: 4
Noise

I have a 2005 Jeep Liberty with 56000 miles, automatic 4x4 3.7 engine. I have a noise that sounds like a rattle/grind something, only when I turn left (not right) and even worse when in 4x4. The local garage checked everything they could while on the hoist and replace the rear brakes and rear right wheel bearing as that was where the noise seemed to be coming from? The jeep dealership could hear it but did not know what it was. I personally do not want to take it too far from home with that going on. Anyone have any ideas. My latest idea is a transmission shop is going to hook up speakers on the unde arrage and he will be able to turn one on and off and try to get an idea where the noise is coming from. By the way both differentials have been serviced along with the transfer case and the 4x4 works perfectly

mrny is offline   Reply With Quote
Unread 07-09-2012, 12:56 PM   #2
3Wide
Registered User
2004 KJ Liberty 
 
Join Date: Feb 2010
Location: Yorkville, ILL
Posts: 72
You said you only hear the noise when turning or in 4X4, that sounds like a front CV issue
3Wide is offline   Reply With Quote
Unread 07-10-2012, 02:57 AM   #3
mrny
Registered User
 
Join Date: Jul 2012
Location: Kalamazoo, mi
Posts: 4
Yes only when turning Left (not right) hear it when in 4x4 or not in 4x4. It sounds like its undercarriage right rear but noise transfers. I cannot sell or trade this Jeep in this condition, very disappointed.
mrny is offline   Reply With Quote
Unread 07-10-2012, 09:04 AM   #4
Clockworkorange
Registered User
2006 KJ Liberty 
 
Join Date: May 2007
Location: Hamilton Ontario Canada
Posts: 84
On my 06 the rear brake backing plates are riveted to the hub.
The rivets rusted and the plate came loose. It caused the sound that you discribe. I drilled out the old rivets, installed new ones, done.
Clockworkorange is offline   Reply With Quote
Reply
Thread Tools


Suggested Threads





Jeep, Wrangler, Cherokee, Grand Cherokee, and other models are copyrighted and trademarked to Jeep/Chrysler Corporation. JeepForum.com is not in any way associated with Jeep or the Chrysler Corp.