post #1 of Old 05-16-2013, 06:34 AM Thread Starter
DarkSport11
Registered User
2011 KK Liberty 
 
Join Date: Mar 2013
Location: Farmingville
Posts: 205
No instrument panel lights

I changed a burned out shift indicator bulb in the center console and it still doesn't light. Yesterday I drove the truck for the first time at night and now my dash doesn't light up either. Everything was fine until I replaced the bulb at the gear selector. I checked the 15 amp fuse and it's good, what else could be causing this all of a sudden?

DarkSport11 is offline  
post #2 of Old 05-16-2013, 07:48 AM
Billwill
Registered User
2002 KJ Liberty 
 
Join Date: Jul 2007
Location: Hoedspruit, South Africa
Posts: 1,282
Quote:
Originally Posted by Garnet02Sport View Post
I changed a burned out shift indicator bulb in the center console and it still doesn't light. Yesterday I drove the truck for the first time at night and now my dash doesn't light up either. Everything was fine until I replaced the bulb at the gear selector. I checked the 15 amp fuse and it's good, what else could be causing this all of a sudden?

You obviously have tried turning the cluster dimmer switch on the left stalk next to the steering column?

2002 2.5 Export CRD Manual 5 speed.
Billwill is offline  
post #3 of Old 05-16-2013, 07:54 PM Thread Starter
DarkSport11
Registered User
2011 KK Liberty 
 
Join Date: Mar 2013
Location: Farmingville
Posts: 205
Found the issue and everything is working again including the gear selector light on the console. The owners manual said fuse #34 which is a 15A is for the dash, courtesy and console indicator lamps. When I pulled it was good so just for the heck of it I started to pull out the other fuses and checked them. When I got to #9 cavity and pulled out the 10A fuse it was bad. I found out that 9, 13 and 34 have the instrument cluster and console shift indicator lamp tied into them some way or another.

Last edited by DarkSport11; 05-16-2013 at 09:38 PM.
DarkSport11 is offline  
post #4 of Old 05-17-2013, 01:47 AM
Billwill
Registered User
2002 KJ Liberty 
 
Join Date: Jul 2007
Location: Hoedspruit, South Africa
Posts: 1,282
Quote:
Originally Posted by Garnet02Sport View Post
Found the issue and everything is working again including the gear selector light on the console. The owners manual said fuse #34 which is a 15A is for the dash, courtesy and console indicator lamps. When I pulled it was good so just for the heck of it I started to pull out the other fuses and checked them. When I got to #9 cavity and pulled out the 10A fuse it was bad. I found out that 9, 13 and 34 have the instrument cluster and console shift indicator lamp tied into them some way or another.

Great The Owners' manual is notorious for incomplete/incorrect fuse information....you need to check the circuit diagrams for slightly more accurate information.

2002 2.5 Export CRD Manual 5 speed.
Billwill is offline  
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome