New member with an old problem - blend door actuator... - JeepForum.com
Search  
Sign Up   Today's Posts
User: Pass: Remember?
Advertise Here
Jeep Home Jeep Forum Jeep Classifieds Jeep Registry JeepSpace Jeep Reviews Jeep Gallery Jeep Clubs Jeep Groups Jeep Videos Jeep Events Jeep Articles
Go Back JeepForum.com > Models > Jeep Liberty Forums > KJ Liberty Forum > New member with an old problem - blend door actuator...

Introducing MONSTALINER™ UV Permanent DIY Roll On Bed LineFS: Jeep Fog Light LED Bulbs! Several Brightness Options! Clayton Off Road JK Short Arm Suspension Kits

Reply
Unread 02-24-2011, 01:32 PM   #1
Boatman2
Registered User
 
Join Date: Feb 2011
Location: Annapolis, MD
Posts: 3
New member with an old problem - blend door actuator...

I have an 02 Liberty that now has suffered from the three seemingly chronic Liberty problems - (1) heater core leaked which I replaced last fall, (2) rear driver window regulator failed which I machined an improved replacement for this winter, and (3) now the blend door actuator has failed. Car had the common symptoms - vent controls work but no heat from any vents.

I found a way to remove the regulator without removing the dash. It involved using a dremel to remove some of the plastic inner dash bracketry (which didn't seem to weaken the dash.)

When I removed the actuator I found that the blend doors seem to be OK, I can manually move the door shaft from lock to lock and get hot and cold air. However, when I use the heat control to control the actuator something very weird happens. The actuator responds correctly to small heat knob inputs in both directions (hot and cold), but if you put the heat knob full hot or full cold, the actuator keeps turning in either direction. It never hits a maximum.

Is this a problem with the actuator or the heat control panel? I tend to think it's the actuator but wanted to get any advice you all may have.

Thanks...Steve.

Boatman2 is offline   Reply With Quote
Unread 02-26-2011, 07:06 AM   #2
Boatman2
Registered User
 
Join Date: Feb 2011
Location: Annapolis, MD
Posts: 3
Any ideas ???

Any idea whether the controller or actuator is faulty???

Any experiences appreciated.

Thanks...Steve.
Boatman2 is offline   Reply With Quote
Reply
Thread Tools


Suggested Threads





Jeep, Wrangler, Cherokee, Grand Cherokee, and other models are copyrighted and trademarked to Jeep/Chrysler Corporation. JeepForum.com is not in any way associated with Jeep or the Chrysler Corp.