JeepForum.com

JeepForum.com (http://www.jeepforum.com/forum/)
-   KJ Liberty Forum (http://www.jeepforum.com/forum/f28/)
-   -   "New" 02 kj owner with concern. (http://www.jeepforum.com/forum/f28/new-02-kj-owner-concern-1538823/)

02blulbrty 06-19-2013 08:57 PM

"New" 02 kj owner with concern.
 
I'm new to the Jeep/forum scene and have a possible problem. I just purchased an 02 kj 3.7 auto, with 99,000+ miles. Question is I just broke 100k and started to notice a "puff puff" sound running throughout the exhaust, speeds up as I accelerate, although doesn't seem to do it until it's at full operating temp. I've tried to google it, youtube it, and search forums, and it's definitely NOT a tapping or any kind of metallic sound. Been very nervous lately coming across all these blown 3.7 engine stories. Thanks in advance!

kjrenegade03 06-21-2013 09:36 AM

Im not the best mechanic around and hopefully someone chimes in that could help you out.

When i got my used kj i had to replace the exhaust from the cats all the way down. I also did rhe head gasket too. Everything with parts was about $1300.

Now you stated that it gets louder/more frequent as you excellerate, this could be possible exhaust rot and there is a leak somewhere. Should be simple enough to get under there and visually see if there is any carbon build up in any area. Look for dark black spots along the pipe, if you see some mark it and turn the engine on to see if exhaust is leaking through. Also the manifold gasket may have failed. This is a bit trcky since it is hard to see, but again look for any discoloration.

As for the head gasket, telltale sign that this is bad would be oil dripping somewhere, usually it starts real small, but you may be able to notice drops in oil level over time.

Start with the exhaust pipes and work your way to the engine. Let us know how you did.

02blulbrty 06-22-2013 07:36 PM

Thank you for the advice. I do have an update, does not make "puff" sound until its warmed up. Also upon acceleration the "puff" speeds up and disappears. I am somewhat mechanically inclined but some things just stump me.

02blulbrty 06-22-2013 07:49 PM

I have a two week vacation coming up next month so I will have to wait till then to get it figured out. Will definitely update on any findings. Thanks again guys and gals.

02blulbrty 07-15-2013 08:25 PM

Finally, the vacay is here. I've had time to investigate the noise, and have determined it is definitely the power steering pump. Whines and groans after it sits overnight and as soon as it warms up it make that poof sound like slapping your hand over an open fence post. $60-$70 fix, not bad.

kjrenegade03 07-16-2013 12:09 AM

Glad it wasnt anything major. :)

02blulbrty 07-16-2013 08:18 PM

Any ideas on the back hatch glass that's missing the shock mounts? Do I need a whole new glass piece or can you get new ones and epoxy them on? Tired of holding it up for groceries and such.

kjrenegade03 07-17-2013 09:14 AM

Is the the piston missing or is it the ball mount that is missing? Pictures?

02blulbrty 07-20-2013 04:57 PM

there is nothing left on the back glass, totally bare. I was going to order new lift shocks but there is nothing to attach to. The metal ball mounts on the frame are there, nothing on the glass whatsoever.
Try to get pics up soon.


The time now is 10:22 PM.

Powered by vBulletin Version 3.8.4
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.