May need blower motor not sure - JeepForum.com
Search  
Sign Up   Today's Posts
User: Pass: Remember?
Advertise Here
Jeep Home Jeep Forum Jeep Classifieds Jeep Registry JeepSpace Jeep Reviews Jeep Gallery Jeep Clubs Jeep Groups Jeep Videos Jeep Events Jeep Articles
Go Back JeepForum.com > Models > Jeep Liberty Forums > KJ Liberty Forum > May need blower motor not sure

The RuffStuff "I can't go to EJS" Sale!Offset Tie Rod Kit From RuffStuff!Check out our NEW Steering Stuff!

Reply
Unread 08-15-2013, 08:31 AM   #1
SandoKJ
Registered User
 
Join Date: Jan 2013
Posts: 18
May need blower motor not sure

Jeep wont blow. has been acting up for about two weeks where sometimes only fourth speed will work then all speeds then one and two but not three or four. Then for about five days only fourth speed worked so i thiught blower resistor. Yesterday i bought the resistor but before i put it in it would not blow qt any speed. put in new resistor and she still wont blow WTF

SandoKJ is offline   Reply With Quote
Unread 08-15-2013, 08:41 AM   #2
allin44
Registered User
2002 KJ Liberty 
 
Join Date: Jun 2009
Location: brandon
Posts: 25
Quote:
Originally Posted by SandoKJ View Post
Jeep wont blow. has been acting up for about two weeks where sometimes only fourth speed will work then all speeds then one and two but not three or four. Then for about five days only fourth speed worked so i thiught blower resistor. Yesterday i bought the resistor but before i put it in it would not blow qt any speed. put in new resistor and she still wont blow WTF
Mine did the same thing. I went to the auto wrecker and bought a used blower motor for $20 and replaced it myself. Works fine now.
allin44 is offline   Reply With Quote
Unread 08-15-2013, 02:47 PM   #3
scottcason
Registered User
2005 KJ Liberty 
 
Join Date: Jul 2013
Location: LaGrange, KY
Posts: 13
Quote:
Originally Posted by SandoKJ View Post
Jeep wont blow. has been acting up for about two weeks where sometimes only fourth speed will work then all speeds then one and two but not three or four. Then for about five days only fourth speed worked so i thiught blower resistor. Yesterday i bought the resistor but before i put it in it would not blow qt any speed. put in new resistor and she still wont blow WTF
Sure it's not the switch?
scottcason is offline   Reply With Quote
Unread 08-15-2013, 09:52 PM   #4
SandoKJ
Registered User
 
Join Date: Jan 2013
Posts: 18
I am not sure what it is. I am electrically incapable... probably just bring to local shop
SandoKJ is offline   Reply With Quote
Unread 08-16-2013, 02:08 AM   #5
Billwill
Registered User
2002 KJ Liberty 
 
Join Date: Jul 2007
Location: South Africa
Posts: 900
Quote:
Originally Posted by SandoKJ View Post
I am not sure what it is. I am electrically incapable... probably just bring to local shop

Check the fuses, fuse 1 (40 Amp) in the Power Distribution Center under the hood. One side of the blower motor goes straight to ground...via the various resistors in series in the resistor block....Black/Tan wire. The other side from the fuse, Red/Light Blue carries the +12 volts.

If you have a meter check that this +12 volts is on the Red/Light Blue wire with respect to ground.


If you jumper pin 30 to pin 87 in the Blower Motor Relay socket the blower motor should run unless it is missing the ground or has burnt out. If this does work then there is something wrong in the relay area.
__________________
2002 2.5 Export CRD Manual 5 speed.
Billwill is offline   Reply With Quote
Unread 09-03-2013, 12:24 PM   #6
kalexyck
Registered User
2003 KJ Liberty 
 
Join Date: Sep 2013
Location: Winkler, MB
Posts: 1
Blower motor

Change your blower motor resistor behind your glovebox. When you only get high or off, your resistor is no longer working as that is what allows different fan speeds. I changed mine and it solved the problem.
kalexyck is offline   Reply With Quote
Unread 09-04-2013, 02:21 AM   #7
Billwill
Registered User
2002 KJ Liberty 
 
Join Date: Jul 2007
Location: South Africa
Posts: 900
Quote:
Originally Posted by kalexyck View Post
Change your blower motor resistor behind your glovebox. When you only get high or off, your resistor is no longer working as that is what allows different fan speeds. I changed mine and it solved the problem.

This was the first thing that the OP changed


That said though....he may have had a new resistor block that was dead on arrival and another one could be tried. I prefer to use a multimeter on problems like this rather than throw money at simply replacing parts!
__________________
2002 2.5 Export CRD Manual 5 speed.
Billwill is offline   Reply With Quote




Jeep, Wrangler, Cherokee, Grand Cherokee, and other models are copyrighted and trademarked to Jeep/Chrysler Corporation. JeepForum.com is not in any way associated with Jeep or the Chrysler Corp.