KJ hesitates at 50 mph during on-ramp. Help - JeepForum.com
Search  
Sign Up   Today's Posts
User: Pass: Remember?
Advertise Here
Jeep Home Jeep Forum Jeep Classifieds Jeep Registry JeepSpace Jeep Reviews Jeep Gallery Jeep Clubs Jeep Groups Jeep Videos Jeep Events Jeep Articles
Go Back JeepForum.com > Models > Jeep Liberty Forums > KJ Liberty Forum > KJ hesitates at 50 mph during on-ramp. Help

Poison spyder items @ oconee off road 706 534 9955FrEaKy FrIdAy SaLe!!!!NEW!! HMF 50"-52" light bar mounting brackets!!

Reply
Unread 07-01-2010, 02:52 PM   #1
pt2005
Registered User
2014 WK 
 
Join Date: Jun 2010
Location: california
Posts: 45
KJ hesitates at 50 mph during on-ramp. Help

Hi,

Lately, the car shows some performance degrade. I switched to synthetic oil, changed oil filter, air filter, sparks. I even threw in a Chrevron Techron Fuel System Cleaner and a Lucas Upper Cylinder tuneup in a bottle. The car is now performing a little better but not to the level I want (2005 4x2 130K). Now, when I am on-ramp trying to get to 60 - 65 mph to merge to traffic, the car hesitates/shakes and does not accelerate well. When this happens the speedo reads 45-50 mph. Once it gets to 60, it runs smooth and can get to 80+ easily. I do have the same hesitate/shake problem when I am running on surface street at 50 mph and let loose the gas pedal to either prepare to brake or just to slow down. I am not sure if this has anything to do with the throttle body (serviced at 60K). Any comments?

Thanks

__________________
2014 Grand Cherokee 3.6 Laredo 4x2
2005 Liberty Sport 3.7 4x2 (Sold)
pt2005 is offline   Reply With Quote Quick reply to this message
Unread 07-01-2010, 05:21 PM   #2
oznext
Registered User
2003 KJ Liberty 
 
Join Date: Apr 2010
Location: Livermore, Ca
Posts: 47
I had this issues (hesitation)with a 5.7 expedition...cause: the gap of the spark plugs was not messure when installing...
oznext is offline   Reply With Quote Quick reply to this message
Unread 07-03-2010, 05:06 PM   #3
04KJlimited
Registered User
2004 KJ Liberty 
 
Join Date: Jan 2007
Location: connecticut
Posts: 165
what plugs did you put in? jeeps typically like champions. lawnmowers do too LOL.
04KJlimited is offline   Reply With Quote Quick reply to this message
Unread 07-03-2010, 10:01 PM   #4
pt2005
Registered User
2014 WK 
 
Join Date: Jun 2010
Location: california
Posts: 45
Quote:
Originally Posted by 04KJlimited View Post
what plugs did you put in? jeeps typically like champions. lawnmowers do too LOL.
I used Mopar original part. I don't think the problem is with the plugs because it happened before and after the new plugs. I remember at 60K I had the dealer perform "fuel induction service" and "throttle body service". After those services the car ran very good. Looks like it's the time to do those services again. I don't have the money now. That's why I am trying to see there are alternatives to the dealer' services.
__________________
2014 Grand Cherokee 3.6 Laredo 4x2
2005 Liberty Sport 3.7 4x2 (Sold)

Last edited by pt2005; 07-04-2010 at 12:15 AM..
pt2005 is offline   Reply With Quote Quick reply to this message
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.
Note: All free e-mails have been banned due to mis-use. (Yahoo, Gmail, Hotmail, etc.)
Don't have a non-free e-mail address? Click here for a solution: Manual Account Creation
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.


Thread Tools






Jeep, Wrangler, Cherokee, Grand Cherokee, and other models are copyrighted and trademarked to Jeep/Chrysler Corporation. JeepForum.com is not in any way associated with Jeep or the Chrysler Corp.