KJ hesitates at 50 mph during on-ramp. Help - JeepForum.com

 
LinkBack Thread Tools
post #1 of 4 Old 07-01-2010, 02:52 PM Thread Starter
pt2005
Registered User
2014 WK 
 
Join Date: Jun 2010
Location: california
Posts: 46
KJ hesitates at 50 mph during on-ramp. Help

Hi,

Lately, the car shows some performance degrade. I switched to synthetic oil, changed oil filter, air filter, sparks. I even threw in a Chrevron Techron Fuel System Cleaner and a Lucas Upper Cylinder tuneup in a bottle. The car is now performing a little better but not to the level I want (2005 4x2 130K). Now, when I am on-ramp trying to get to 60 - 65 mph to merge to traffic, the car hesitates/shakes and does not accelerate well. When this happens the speedo reads 45-50 mph. Once it gets to 60, it runs smooth and can get to 80+ easily. I do have the same hesitate/shake problem when I am running on surface street at 50 mph and let loose the gas pedal to either prepare to brake or just to slow down. I am not sure if this has anything to do with the throttle body (serviced at 60K). Any comments?

Thanks


2014 Grand Cherokee 3.6 Laredo 4x2
pt2005 is offline  
Sponsored Links
Advertisement
 
post #2 of 4 Old 07-01-2010, 05:21 PM
oznext
Registered User
2003 KJ Liberty 
 
Join Date: Apr 2010
Location: Livermore
Posts: 47
I had this issues (hesitation)with a 5.7 expedition...cause: the gap of the spark plugs was not messure when installing...
oznext is offline  
post #3 of 4 Old 07-03-2010, 05:06 PM
04KJlimited
Registered User
2004 KJ Liberty 
 
Join Date: Jan 2007
Location: connecticut
Posts: 167
what plugs did you put in? jeeps typically like champions. lawnmowers do too LOL.
04KJlimited is offline  
post #4 of 4 Old 07-03-2010, 10:01 PM Thread Starter
pt2005
Registered User
2014 WK 
 
Join Date: Jun 2010
Location: california
Posts: 46
Quote:
Originally Posted by 04KJlimited View Post
what plugs did you put in? jeeps typically like champions. lawnmowers do too LOL.
I used Mopar original part. I don't think the problem is with the plugs because it happened before and after the new plugs. I remember at 60K I had the dealer perform "fuel induction service" and "throttle body service". After those services the car ran very good. Looks like it's the time to do those services again. I don't have the money now. That's why I am trying to see there are alternatives to the dealer' services.

2014 Grand Cherokee 3.6 Laredo 4x2

Last edited by pt2005; 07-04-2010 at 12:15 AM.
pt2005 is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.



Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome