It was just the lifters! - JeepForum.com
Search  
Sign Up   Today's Posts
User: Pass: Remember?
Advertise Here
Jeep Home Jeep Forum Jeep Classifieds Jeep Registry JeepSpace Jeep Reviews Jeep Gallery Jeep Clubs Jeep Groups Jeep Videos Jeep Events Jeep Articles
Go Back JeepForum.com > Models > Jeep Liberty Forums > KJ Liberty Forum > It was just the lifters!

Rough Country Deals at JeepHut.comSave at JeepHut on Smittybilt Soft topsUp to $75 Cash Back on Your ARB Fridge Freezer Purchase

Reply
Unread 01-28-2012, 05:32 AM   #1
mt7558
Registered User
2005 KJ Liberty 
 
Join Date: Jan 2012
Location: Fuquay Varina, NC
Posts: 2
It was just the lifters!

Hi folks, I just R&Red the lifters in an 05 Lib with a 2.4l. I cheated and did not fully remove the cam shafts, but just removed the hold downs and lifted them just enough to remove the rockers and pull the lifters. I did each side separately, and reassembled with proper torque and so on. When started it now sounds like it has a vacuum leak (can't find one) and a miss and has thrown a P0172 code. Any help would be, well keep me out of the dog house.

Thanks,


Mark

mt7558 is offline   Reply With Quote
Unread 05-14-2012, 08:59 AM   #2
Nmcgrawj
Registered User
2004 KJ Liberty 
 
Join Date: May 2012
Location: Indianapolis, In
Posts: 13
You ever find the root cause?
Nmcgrawj is offline   Reply With Quote




Jeep, Wrangler, Cherokee, Grand Cherokee, and other models are copyrighted and trademarked to Jeep/Chrysler Corporation. JeepForum.com is not in any way associated with Jeep or the Chrysler Corp.