Jeep won't start! 02 Liberty - JeepForum.com
 
LinkBack Thread Tools
post #1 of 5 Old 09-07-2006, 02:39 PM Thread Starter
Xerxes600rr
Registered User
 
Join Date: Aug 2006
Location: Michigan
Posts: 7
Jeep won't start! 02 Liberty

I need help. I turned my ignition to the on position w/o starting my jeep. I extracted a cd and everything was fine. Now i can turn it to accessory and everything works. When i try to turn it over nothing works. My battery cell is green, although it's 4.5 y/o and it will start when it is jumped. I drove it for 30 min turned it off and the same thing. Sounds like the altenator with the battery not holding the charge, however this is where it gets confusing. If i open the door or try to turn the headlights on, anything like that, the tailgate door lock or window latch goes crazy, it won't stop going. I'm afraid i'm going to burn my motor out. Could it be a faulty circuit relay/fuse/battery/ or altenator. Anything would help, don't have money to take it in right now. Bought too much parts. I'm out of ideas.

Xerxes600rr is offline  
Sponsored Links
Advertisement
 
post #2 of 5 Old 09-07-2006, 03:09 PM
jeepjeepster
Registered User
 
Join Date: Dec 2004
Posts: 3,131
Bad battery. If it will run for 30minutes, the alternator is fine.
jeepjeepster is offline  
post #3 of 5 Old 09-07-2006, 03:44 PM
skleinsmith
Registered User
 
Join Date: Nov 2004
Location: Igo, CA (Near CA)
Posts: 108
Also, some of the "switches/relays" go crazy when they do not get enough voltage, the click in and out. I would try a new Battery 1st, a good parts store can charge and load test yours to make sure it is not the alternator.

Shawn Kleinsmith
Igo, CA (Near Redding)
2004 Liberty (3.6 v6 gas) - Rocky Mountain Edit - Silver/charcoal
skleinsmith is offline  
 
post #4 of 5 Old 09-10-2006, 10:51 AM
lucas/liberty
Registered User
 
lucas/liberty's Avatar
 
Join Date: Nov 2003
Location: reno,NV
Posts: 344
how old is the battery, and where do you live(elevation wise), replace the battery first...

...you dont stop playing just because you get old, you get old because you stop playing...
...If a man speaks in the woods where there is no woman to hear him, is he still wrong?

Wife=2002 jeep liberty sports traded it in for an RX330 lexus
===2007 nissan Xterra X
lucas/liberty is offline  
post #5 of 5 Old 09-10-2006, 12:59 PM
CRD4Liberty
Registered User
 
Join Date: Aug 2005
Posts: 453
Pull out your mutlimetter with the engine running and the voltage should be 14.2 to 13.8 VDC. If it is the alternator is good, battery isn't. Could also be a bad/dirty battery connection though I doubt it, as when you jumpstart a battery you are bypassing the important battery post to battery lead connection that may need cleaned or tightened.
CRD4Liberty is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.



Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Similar Threads
Thread Thread Starter Jeep Forums Replies Last Post
Mopar Remote Start for 2002 Jeep Liberty Limited jaiasmit KJ Liberty Forum 1 01-16-2010 08:42 PM
03 Liberty No start bob55 KJ Liberty Forum 3 08-22-2009 10:52 PM
Jeep Remote Start Problems with Liberty? Divinitous KJ Liberty Forum 9 01-24-2009 08:44 AM
Remote Start for a 2002 Jeep Liberty? mbows82 KJ Liberty Forum 5 12-15-2007 07:11 AM
Why oh why does My '04 Liberty not start??? NJinTX KJ Liberty Forum 8 01-25-2005 11:52 AM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome