post #1 of Old 05-26-2014, 11:46 AM Thread Starter
jessi88
Registered User
 
Join Date: May 2014
Location: fayetteville
Posts: 1
Jeep Lierty wont stay running

We have a 2002 Jeep Liberty 3.7 L -- Has ran great the past 6 years we have had it.. The other day my husband was driving to work and it stalled and wouldn't start back up-- He got pulled home.. We have been trying to find out what the issue is and are having no luck. The jeep will start if you jump it, and it will stay running for a few minutes and than stall. We have taken the alternator and battery to get tested and both test came back fine. No codes coming up when my husband runs it.

Husband thinks its something electrical. Any advice would be greatly appreciated!

jessi88 is offline  
post #2 of Old 05-27-2014, 03:13 AM
Billwill
Registered User
2002 KJ Liberty 
 
Join Date: Jul 2007
Location: Hoedspruit, South Africa
Posts: 1,282
Quote:
Originally Posted by jessi88 View Post
We have a 2002 Jeep Liberty 3.7 L -- Has ran great the past 6 years we have had it.. The other day my husband was driving to work and it stalled and wouldn't start back up-- He got pulled home.. We have been trying to find out what the issue is and are having no luck. The jeep will start if you jump it, and it will stay running for a few minutes and than stall. We have taken the alternator and battery to get tested and both test came back fine. No codes coming up when my husband runs it.

Husband thinks its something electrical. Any advice would be greatly appreciated!
Fuel filter clogged or bad fuel filter?

Does it stall when hot....the crank sensor and cam sensor can give heat related problems....you need to pull these sensors out and measure the resistance when cold using an Ohms meter. Now heat them up with a hair dryer and if the resistance readings start going crazy then you have a bad sensor.

Also try swapping over the ASD relay in the box under the hood with an identical one...the Blower Motor relay for instance I think.

If you have the SKIS anti theft installed then if the chipped key is not recognised by the PCM, the SKIS light flashes and the engine starts but cuts out after a few seconds....not the few minutes you mention though!

2002 2.5 Export CRD Manual 5 speed.
Billwill is offline  
Reply

Tags
liberty , stalling


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome