Jeep Liberty 2.8 L Diesel ETC Light Flashing! - Page 2 - JeepForum.com
Search  
Sign Up   Today's Posts
User: Pass: Remember?
Advertise Here
Jeep Home Jeep Forum Jeep Classifieds Jeep Registry JeepSpace Jeep Reviews Jeep Gallery Jeep Clubs Jeep Groups Jeep Videos Jeep Events Jeep Articles
Go Back JeepForum.com > Models > Jeep Liberty Forums > KJ Liberty Forum > Jeep Liberty 2.8 L Diesel ETC Light Flashing!

The Original 3/8" Ruffstuff Diff Cover!Ruffstuff 3 Link Kit!The Ruffstuff Optima Battery Box!

Reply
Unread 08-26-2010, 04:56 PM   #16
raenram
Registered User
 
Join Date: Dec 2009
Location: Chile
Posts: 19
Fixed it, I had to change the glow plugs. Once i did it, ETC light disappeared.

raenram is offline   Reply With Quote
Unread 08-26-2010, 05:22 PM   #17
95BadBoy
Moderator
2005 TJ Wrangler 
 
Join Date: May 2006
Location: Grand Forks, ND
Posts: 2,833
Quote:
Originally Posted by raenram View Post
Fixed it, I had to change the glow plugs. Once i did it, ETC light disappeared.

Good to hear, how did the tips of the glow plugs look?

I ask - as there have been more than a few that the tips have actually cracked and some have dropped pieces into places where we all know they should not go.
__________________
05 TJ RME 42RLE with some things
05 KJ CRD 545RFE, GDE Eco tune, Franky II, Al's 4.5 A-arms, JK Rubi Moabs, Silent Armors 245-70-17's, Spidertrax Adapters, Rola Basket, Fumoto Valve, Pinch welds pounded

FS or FT (2) JK Rubi 17" Moab Rims - really nice shape
Need JK Rear Spare tire bracket for project
95BadBoy is offline   Reply With Quote
Unread 10-21-2010, 08:11 AM   #18
Giulio
Registered User
 
Join Date: Oct 2010
Location: San Jose
Posts: 2
problem with ETC light

Hi guys, I also have a Jeep Liberty 2007, 2.8 diesel, every morning I got the ETC light on, but as the manual says, after turning the key several times from OFF to ON position, it disappears, the thing is, do I have to do it everyday? how can I solve the problem for good?
car is running great, no power loss whatsoever. have no idea what could have caused the lighting
Giulio is offline   Reply With Quote
Unread 10-21-2010, 08:40 AM   #19
95BadBoy
Moderator
2005 TJ Wrangler 
 
Join Date: May 2006
Location: Grand Forks, ND
Posts: 2,833
Is yours a US model? To my knowledge -US Libby's only got the CRD's in 05 & 06 is why I ask.
__________________
05 TJ RME 42RLE with some things
05 KJ CRD 545RFE, GDE Eco tune, Franky II, Al's 4.5 A-arms, JK Rubi Moabs, Silent Armors 245-70-17's, Spidertrax Adapters, Rola Basket, Fumoto Valve, Pinch welds pounded

FS or FT (2) JK Rubi 17" Moab Rims - really nice shape
Need JK Rear Spare tire bracket for project
95BadBoy is offline   Reply With Quote
Unread 10-21-2010, 02:28 PM   #20
raenram
Registered User
 
Join Date: Dec 2009
Location: Chile
Posts: 19
Giulio, try changing your glow plugs and clean your air intake, i had the same problem.
Hope u can fix it. Let me know.
raenram is offline   Reply With Quote
Unread 10-22-2010, 09:11 AM   #21
Giulio
Registered User
 
Join Date: Oct 2010
Location: San Jose
Posts: 2
Thank you very much, problem solved!
Giulio is offline   Reply With Quote
Reply
Thread Tools


Suggested Threads





Jeep, Wrangler, Cherokee, Grand Cherokee, and other models are copyrighted and trademarked to Jeep/Chrysler Corporation. JeepForum.com is not in any way associated with Jeep or the Chrysler Corp.