Ignition switch problem - JeepForum.com
 
LinkBack Thread Tools
post #1 of 4 Old 12-14-2010, 07:38 PM Thread Starter
keiths
Registered User
2003 KJ Liberty 
 
Join Date: Dec 2010
Location: springfield
Posts: 2
Ignition switch problem

2003 Liberty, 4wd, auto. Ignition switch only rotates to "run" position, won't go into "start". Tried the park lock cable, that seems good. Any clues? Also, the steering wheel won't lock (just bought this thing, not sure if that's normal). Everything seemed fine. Just came back from shopping, unloaded, parked, next day wouldn't start. Thanks...

keiths is offline  
Sponsored Links
Advertisement
 
post #2 of 4 Old 12-15-2010, 09:38 PM
richd
Registered User
2008 KK Liberty 
 
Join Date: Jun 2008
Location: Arizona
Posts: 1,110
Quote:
Originally Posted by keiths View Post
2003 Liberty, 4wd, auto. Ignition switch only rotates to "run" position, won't go into "start". Tried the park lock cable, that seems good. Any clues? Also, the steering wheel won't lock (just bought this thing, not sure if that's normal). Everything seemed fine. Just came back from shopping, unloaded, parked, next day wouldn't start. Thanks...
You might need to check the brake transmission shift interlock cable adjustment.If it checks out, then could be you ignition lock cylinder.
richd is offline  
post #3 of 4 Old 12-16-2010, 12:35 PM Thread Starter
keiths
Registered User
2003 KJ Liberty 
 
Join Date: Dec 2010
Location: springfield
Posts: 2
Removed lock cylinder, it seems smooth. Also, this was the first time the vehicle had been in 4wd in a couple of years, does that help diagnose?
keiths is offline  
post #4 of 4 Old 12-16-2010, 09:30 PM
richd
Registered User
2008 KK Liberty 
 
Join Date: Jun 2008
Location: Arizona
Posts: 1,110
Quote:
Originally Posted by keiths View Post
Removed lock cylinder, it seems smooth. Also, this was the first time the vehicle had been in 4wd in a couple of years, does that help diagnose?
I dont see how 4WD would cause this.Is it shifting out of park,and going in to park with out any problems?
richd is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.



Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Similar Threads
Thread Thread Starter Jeep Forums Replies Last Post
Ignition backorder?? Tara22 KJ Liberty Forum 1 09-19-2010 05:52 PM
2005 liberty 3.7 serious ignition problem jjal881 KJ Liberty Forum 10 04-22-2010 05:47 PM
Big problem with Back-up switch need help ASAP 04LibertyRen KJ Liberty Forum 1 01-15-2010 07:44 PM
Ignition switch blueboy610 KJ Liberty Forum 2 11-18-2009 10:26 AM
My ignition switch is stuck and trying to change out. bradsy KJ Liberty Forum 4 05-27-2007 04:26 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome