help! Liberty wont start! - JeepForum.com
Search  
Sign Up   Today's Posts
User: Pass: Remember?
Advertise Here
Jeep Home Jeep Forum Jeep Classifieds Jeep Registry JeepSpace Jeep Reviews Jeep Gallery Jeep Clubs Jeep Groups Jeep Videos Jeep Events Jeep Articles
Go Back JeepForum.com > Models > Jeep Liberty Forums > KJ Liberty Forum > help! Liberty wont start!

Smittybilt Products at Oconee Off-Road!Building a Bumper?Ruffstuff Axle Simple Swap Kit!

Reply
Unread 11-14-2008, 10:41 AM   #1
rick2010
Registered User
1987 YJ Wrangler 
 
Join Date: Jul 2008
Location: MARYLAND
Posts: 24
help! Liberty wont start!

Buddy of mine has an 03 liberty and he went to start it this morning and it was dead. I went to jump start him and their is power, the jeep will start, but soon as it starts it dies immediately.

It has a full tank of gas

all the spark plugs are tight

no loose wires

don't really know what to look for......any ideas?

Any help appreciated.

rick2010 is offline   Reply With Quote
Unread 11-14-2008, 10:53 AM   #2
yellocoyote
Registered User
2002 KJ Liberty 
 
Join Date: Oct 2008
Location: Elgin, IL
Posts: 184
Maybe bad fuel filter or fuel pump? How long does it stay running after it is started?
__________________
2002 Liberty Sport 4x4
yellocoyote is offline   Reply With Quote
Unread 11-14-2008, 11:24 AM   #3
Jakked
Registered User
 
Join Date: Aug 2006
Location: Snow country
Posts: 374
More description needed. You said there is power, but you had to jump-start him. What are the circumstances?

Is there power if you don't jump-start him?

Does the Jeep start and then shut off while the two vehicles are still connected to the jumper cables?

If it is a bad battery (or possibly alternator), it is not unheard of to jump-start the vehicle, and then have the vehicle die as soon as you disconnect the jumper cables.
__________________
2004 Liberty Sport 3.7L A/T 4x4 Cmd-Trc
Former 4x4s:
1999 TJ 4.0L I-6 4x4 5-Sp *Mods*
1986 Trooper 2.3L I-4 4x4 5-sp
Jakked is offline   Reply With Quote
Unread 11-14-2008, 12:39 PM   #4
jsc7002
Registered User
1966 CJ5 
 
Join Date: Apr 2008
Location: Wichita, Kansas
Posts: 1,428
is the battery dead? my battery went dead so I jump started it and it just died unless you kept giving it gas
__________________
1966 Jeep CJ5
jsc7002 is offline   Reply With Quote
Unread 11-14-2008, 03:58 PM   #5
DaveJKJ
Registered User
2005 KJ Liberty 
 
Join Date: Nov 2008
Location: stuck in the mud again
Posts: 1,080
I think you need to test the battery. That would be the first and most likely thing to check. You said it is an 03 so is it the original battery? Some of the auto parts places will test them free if you don't have a tester yourself.
__________________
War Veterans Jeep Group #31
Black Jeep Society #217
DaveJKJ is online now   Reply With Quote
Unread 11-14-2008, 09:58 PM   #6
ChvyKc
Registered User
2006 XK Commander 
 
Join Date: Aug 2008
Location: Columbia, SC
Posts: 64
I just posted this in another thread, just thought that I would throw it up here:

Same thing happened to my wife's car when the battery started to die. I pulled the codes with a scanner and came up with the same thing. I ended up replacing the front O2 sensor, IAC and a purge solenoid and it didn't fix it. Everything fixed itself when I replaced the battery.

I don't think that the actual problem was fixed but the car runs fine now. When I would start the car without the battery some of the gauges would flicker but I even had the alternator tested at two different places and it test perfect both times. Good luck figuring out what's wrong with yours. PM me if you need any help.
__________________
-ChvyKc
'06 XK 3.7L (Stock for now)
'07 WK HEMI Limited (Wife's)
ChvyKc is offline   Reply With Quote
Unread 11-14-2008, 10:48 PM   #7
jsc7002
Registered User
1966 CJ5 
 
Join Date: Apr 2008
Location: Wichita, Kansas
Posts: 1,428
the KJ's tend to do some crazy things when the battery dies
__________________
1966 Jeep CJ5
jsc7002 is offline   Reply With Quote
Unread 11-17-2008, 12:15 PM   #8
ATXKJ
Registered User
2005 KJ Liberty 
 
Join Date: Oct 2008
Location: Texas
Posts: 17
Odds are the battery - they have to have enough voltage to turn on the computer - engine running doesn't count if the computer's not on - the engine will die.

(low odds - but another forum someone had key problems - the computer will also turn off the engine if it doesn't recognize the key code)
ATXKJ is offline   Reply With Quote
Unread 12-27-2008, 12:41 PM   #9
rick2010
Registered User
1987 YJ Wrangler 
 
Join Date: Jul 2008
Location: MARYLAND
Posts: 24
Battery replaced.....All is good now
rick2010 is offline   Reply With Quote
Unread 12-27-2008, 03:40 PM   #10
RMRSRT
Registered User
2002 KJ Liberty 
 
Join Date: Nov 2008
Location: Sta
Posts: 11
Whenever my battery drained and I jumped it with another car my jeep would turn over but immediately shut off. I would have to hold onto the gas for a good 10-15 minutes in order for it to stay idling. I guess if the battery is low on charge it would not have enough juice to keep the car running. After pressing on the gas for a while it would be fine. Weird, I know.
RMRSRT is offline   Reply With Quote
Reply
Thread Tools


Suggested Threads





Jeep, Wrangler, Cherokee, Grand Cherokee, and other models are copyrighted and trademarked to Jeep/Chrysler Corporation. JeepForum.com is not in any way associated with Jeep or the Chrysler Corp.