post #1 of Old 11-17-2013, 06:14 PM Thread Starter
red9r
Registered User
 
Join Date: Nov 2013
Location: Warner Robins
Posts: 2
Help Identify 3.7L Engine Harness Connector

After having some work done, I noticed a connector laying in the passenger side of the engine bay that isn't plugged up to anything. Inside the connector is pretty clean leading me to believe it was plugged up to something prior to having work done. I looked around and couldn't find where it should plug up to. Does anyone recognize this connector and know where is goes?

Thanks in advance!

Attached Images
 
red9r is offline  
post #2 of Old 11-17-2013, 06:42 PM
tjkj2002
Registered User
2002 KJ Liberty 
 
Join Date: Dec 2009
Location: Colorado
Posts: 8,360
Cruise control connector which looks like you don't have that option.Many times they have one harness and leave connectors unhooked for options not on your vehicle.

'02 Liberty sitting on 35" tires,HP44,RockJock60,and AtlasII t-case
tjkj2002 is offline  
post #3 of Old 11-17-2013, 07:07 PM Thread Starter
red9r
Registered User
 
Join Date: Nov 2013
Location: Warner Robins
Posts: 2
Thanks for your help. That was bugging me.
red9r is offline  
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome