Heater/AC Blower only works on High - JeepForum.com
 
LinkBack Thread Tools
post #1 of 7 Old 12-14-2008, 11:33 AM Thread Starter
Sevenfootman
Registered User
 
Join Date: Dec 2008
Location: colorado
Posts: 1
Heater/AC Blower only works on High

The blower in my wifes 06 liberty only works on 4 (or high). The other day when I drove it, it worked on 3 but nothing below that. Now only 4. Checked all the fuses. Any other ideas on what to check and why it works on one setting...but not the other?

Thanks,

SFM

Sevenfootman is offline  
Sponsored Links
Advertisement
 
post #2 of 7 Old 12-14-2008, 11:52 AM
Jakked
Registered User
 
Join Date: Aug 2006
Location: Snow country
Posts: 374
resistor pack needs to be replaced. do a search on this forum, you'll find several threads with instructions on how to DIY if you want to.

2004 Liberty Sport 3.7L A/T 4x4 Cmd-Trc
Former 4x4s:
1999 TJ 4.0L I-6 4x4 5-Sp *Mods*
1986 Trooper 2.3L I-4 4x4 5-sp
Jakked is offline  
post #3 of 7 Old 12-15-2008, 11:40 AM
ashtona
Registered User
 
Join Date: Dec 2008
Location: MA
Posts: 4
My '06 is doing the same thing and sure enough, there is a recall on that very problem. Apparently it "could" cause a fire but in most cases, just burns out like what happened to me, and apparently you.

I would call the dealer before dropping any money into it, no matter how cheap it is to fix.
ashtona is offline  
post #4 of 7 Old 12-15-2008, 02:25 PM
jeepjeepster
Registered User
 
Join Date: Dec 2004
Posts: 2,582
^Two different things.

There is NOT a recall on the resistor packs. Its a very cheap and easy fix.
jeepjeepster is offline  
post #5 of 7 Old 12-15-2008, 02:29 PM
jp7794
Registered User
2006 KJ Liberty 
 
Join Date: Jul 2008
Location: MO
Posts: 383
I lost speed 1 and that is what they replaced. It is still under warranty.
jp7794 is offline  
post #6 of 7 Old 12-19-2008, 10:08 AM
stormcr0w
Registered User
 
Join Date: Dec 2008
Location: Eastern KY
Posts: 7
My extended warranty has a $100 deductible so I found a guy who has the genuine mopar parts on fleabay for about $25 shipped, cause the nearest dealer to me is about 45 minutes away. It took me longer to find my 5/16 socket than it did to replace the dang thing. Works like a charm now.
stormcr0w is offline  
post #7 of 7 Old 12-20-2008, 05:58 AM
skates04
Registered User
 
skates04's Avatar
2008 JK Wrangler 
 
Join Date: Feb 2004
Location: Coloraodo
Posts: 421
Easy fix, get it on-line for half of what the local dealers usaully want. I had to replace one on my old TJ and Sure enough the day after I got my Liberty I had to change it as well.....

Lucas
skates04 is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.



Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Similar Threads
Thread Thread Starter Jeep Forums Replies Last Post
2002 Liberty blower works but will not produce hot air kdjf4 KJ Liberty Forum 2 12-03-2008 03:48 PM
Blower Motor Only Works On 4 HARDEIGHT KJ Liberty Forum 10 01-09-2008 05:31 PM
Fan / Blower switch only works on high skates04 KJ Liberty Forum 3 10-03-2007 08:04 PM
Heater Blower Fan Noise JCL_05_CRD KJ Liberty Forum 2 12-21-2005 04:40 PM
Heater/blower issue Blue_Liberty KJ Liberty Forum 5 11-29-2005 04:37 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome