Hard Shifting after starter replacement - JeepForum.com
 
LinkBack Thread Tools
post #1 of 2 Old 05-28-2013, 05:14 PM Thread Starter
Overlord475
Registered User
2001 XJ Cherokee 
 
Join Date: Jul 2011
Location: Tulsa
Posts: 2
Hard Shifting after starter replacement

After replacing my KJ's starter this past weekend the transmission has begun shifting hard.

Not sure what could be causing this and if it is at all related to the starter replacement.

I did have to remove the forward drive shaft coming from the trans to the front transfer case to remove the starter.

Maybe I didn't quit get it back in snuggly and it's clunking at shifts?

Trans fluid level is fine

Thoughts?

Overlord475 is offline  
Sponsored Links
Advertisement
 
post #2 of 2 Old 06-03-2013, 02:46 PM Thread Starter
Overlord475
Registered User
2001 XJ Cherokee 
 
Join Date: Jul 2011
Location: Tulsa
Posts: 2
While removing the forward drive shaft I knocked loose the front trans speed sensor.

If your trans is downshifting hard check both the speed sensors. They are the driverside of the trans.
Overlord475 is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.



Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome