Few issues, looking for some opinions/assistance. - JeepForum.com
Search  
Sign Up   Today's Posts
User: Pass: Remember?
Advertise Here
Jeep Home Jeep Forum Jeep Classifieds Jeep Registry JeepSpace Jeep Reviews Jeep Gallery Jeep Clubs Jeep Groups Jeep Videos Jeep Events Jeep Articles
Go Back JeepForum.com > Models > Jeep Liberty Forums > KJ Liberty Forum > Few issues, looking for some opinions/assistance.

Engo LED Flush Mount Lights *PAIR* Flood or Spot 1,600 LumYukon Ultimate 35 axle kit for c/clip axles with Yukon ZipRockridge 4WD IS Taking Zone Offroad Suspension Lift Kits

Reply
Unread 03-25-2012, 02:12 PM   #1
kskajohnson
Registered User
 
Join Date: Mar 2012
Posts: 1
Few issues, looking for some opinions/assistance.

First post here....I have a few issues with my 2002 Jeep Liberty (Approx 138K miles) and was looking for some assistance as I'm just not real mechanically inclined and don't want to get raped at the shop (although thats probably going to happen regardless).

Now to the issues:
  • Coolant Leak

    ---I've had an issue over the last month or so with the coolant leaking out leading to the vehicle overheating. The odd thing was that it wasn't visibly leaking out of the vehicle. After talking to a mechanic buddy of mine and having him inspect it, the radiator was terribly beat up and one of the main hoses (upper right) was really swollen and leaking.

    He helped me replaced the radiator and replaced that swollen hose yesterday and I've refilled it with coolant and I think its good to go now but could it be something else or do you think that'd take care of it?

  • A/C Compressor Rattling Noise
    The last week or so, my A/C Compressor was acting up....the pulley would intermittently start and then stop...then start again...then stop and so forth (usually in about 10 second increments)

    It also wasn't blowing much cold air, at all.

    I went ahead and refilled the A/C low fill area as the manual suggested and its now blowing extremely cold air as it should but when I have it on the third/fourth highest settings, it makes an interesting rattling type noise and I'm not real sure what thats all about.

    When I have the A/C shut off, it doesn't make it. It seems to be a bit louder when the gas is pressed while driving.

    I've noticed a slight burning smell (faint, not real strong)

    I'm just leaving it off completely (The A/C) until I'm able to figure out why thats happening and what to do.

  • Starting Issue (Occasionally)

    This has been an issue for a while....I'll turn the key and most of the time, it starts up without any issue.

    Other times, I'll start it up and it wants to kick over but it won't. I release the key and immediately try again and it starts right up. If it doesn't start on the first attempt then it ALWAYS does on the second.

    I've recently changed out the starter and put in a brand new battery and while it sounds like its starting much easier....it occasionally still does the whole starting issue.

    So with a new battery/starter (also put in new spark plugs) and it still occasionally occurring, what else could it be? The battery holds a charge just fine so that leads me to believe it can't be the alternator, could it?

    I'm just not sure what else could cause it to give me trouble on turning the key once in a while but not every time and when it does give me a hassle, it always starts on the second turn of the key.

  • AirBag Light On occasionally

    Lastly....the airbag light comes on the dash once in a while. I'd say probably once every few weeks but then the next time I start the car up, nothing....its just weird that its on once in a while but not every time.

That's it....I appreciate anybodies patience and assistance as this really isn't my thing and before I end up taking it to a shop...I'd like to think I can figure out what is going on with it so I don't get absolutely taken to the cleaners.

Just trying to get another year or so out of the vehicle so I can finish school and get a newer jeep at that time. Any assistance is GREATLY appreciated, thank you.

kskajohnson is offline   Reply With Quote Quick reply to this message
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.
Note: All free e-mails have been banned due to mis-use. (Yahoo, Gmail, Hotmail, etc.)
Don't have a non-free e-mail address? Click here for a solution: Manual Account Creation
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.


Thread Tools


Suggested Threads





Jeep, Wrangler, Cherokee, Grand Cherokee, and other models are copyrighted and trademarked to Jeep/Chrysler Corporation. JeepForum.com is not in any way associated with Jeep or the Chrysler Corp.