-   KJ Liberty Forum (
-   -   Evap system errors with misfiring Cyl 3 (

DinkyDauBilly 10-01-2012 08:37 PM

Evap system errors with misfiring Cyl 3
2002 Jeep Liberty 3.7L, auto, 70k miles, heretofore no problems at all other than a minor evap leak, apparently fixed with a new gas cap about two months ago.

Time to change the plugs, so I replaced the originals with Bosch Platinum iR Fusions. All was swell. Then, whilst traveling down the road, engine temp normal, accelerating, between 55-60 mph the SES came on, started flashing, and the vehicle started running like an unbalanced washing machine. Slowed down, went home, put the code reader on and found P0303.

Electrical connections looked good. Given the recent plug replacement, I thought perhaps I had gotten a bad one, so replaced #3 with another new one, and cleared the code. No joy. Same problem, same conditions. So I swapped coil packs with #1 and tried again. No joy. Same problem, same conditions, same cylinder.

Now, however, in addition to P0303, I had a major evap system leak code. I found that, with dry-rotted hose coming off the LDP and plugging into a tube going forward to the engine compartment. Also found a very loose hose from the canister. Replaced the rotted hose and pushed the other back in place, clamped it, cleared errors, and tried again. The engine was cold, and I was able to accelerate normally to about 70. Then the engine warmed up, and ... I still had the P0303, flashing SES, but now with a minor evap leak.

Now here is an interesting thing. If I accelerate very gently, or do not exceed that 55-60 range, I don't have any problems. And, if I do get the error, and the rough engine because of the misfire ... if I clear the error, the engine runs quite well until I cause the SES to trip. Which is coming first here, the chicken or the egg? Clearing the error 'fixes' the problem?

I'd appreciate any help with this one. TIA.

tjkj2002 10-01-2012 09:41 PM

Try putting in the correct spark plugs and see if that works.Anything bosch does not belong on or in your engine.Copper core plugs only and much cheaper.

AlfaM1keFoxtrot 10-02-2012 12:55 AM

Misfire #3
I read your post and thought this might help. have an '06 Renegade, with the same concern minus the Evap problem. Mine has a 3.7L with th same misfire at idle under a load it runs fine. Replaced all the usual suspects including the #3 injector code came right back. Did some digging on Mitchell on demand... found a bulletin from Chrysler for a misfire. Bottom line it states to replace the #3 intake valve due to the valve not seating correctly. Ill post the bulletin number in the next day of two if ya need it. Hope this helps

DinkyDauBilly 01-02-2013 04:47 PM

OK, I've had this Jeep sitting for the last couple of months. Still has the P0303 error. I have LiveData off the ODB tool posted here: It's a 137 kbyte PDF file. The data includes frames before the trigger, the trigger frame, and then the after trigger frames. The Bank 1 and 2 sensor data looks interesting but I don't know enough about that to grasp the significance. I am not getting a sensor error code.

Detachable 06-10-2013 11:32 AM

Please tell me you've fixed this? I'm having the same exact issue, also 02 and 75k. It only misfires when I try to get up and go like getting on the highway or maintaining highway speeds. Keep it slow and under about 3k, it's great! I first had this problem after I came back from a vacation. Engine light was already on (friends drove it for a few days). I drove it only a blocks for a few days in town thereafter, then it started getting bad at idle. Pulled all the plugs. #6 was gummed up. I swapped the plugs. It seemed to run great for about 1 week. But I never took it up to highway speeds. And now I am where you were with a misfire (no engine light yet- though it did flicker the first time I drove it on the highway) when I try to accelerate hard. Not when I rev it hard, only when I drive it hard. I'm desperate to fix this one, so please if you can update us on your solution.

The time now is 02:43 PM.

Powered by vBulletin Version 3.8.8
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.

User Alert System provided by Advanced User Tagging (Pro) - vBulletin Mods & Addons Copyright © 2017 DragonByte Technologies Ltd.
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2017 DragonByte Technologies Ltd.