Electrical Problems - JeepForum.com
Search  
Sign Up   Today's Posts
User: Pass: Remember?
Advertise Here
Jeep Home Jeep Forum Jeep Classifieds Jeep Registry JeepSpace Jeep Reviews Jeep Gallery Jeep Clubs Jeep Groups Jeep Videos Jeep Events Jeep Articles
Go Back JeepForum.com > Models > Jeep Liberty Forums > KJ Liberty Forum > Electrical Problems

Introducing MONSTALINER™ UV Permanent DIY Roll On Bed LineThe Solution to Radius Arm Bind - Meet Lock-N-LoadFS: Jeep Fog Light LED Bulbs! Several Brightness Options!

Reply
Unread 10-25-2010, 04:33 AM   #1
Chrisfol82
Registered User
 
Join Date: Aug 2006
Location: Pittsburgh, Pa
Posts: 326
Electrical Problems

I have a 2003 Jeep Liberty (cherkoee over in Australia) which is having some electrical problems of some kind.

First thing i noticed was the auto door unlocker didnt work when i went to unlock the doors the other day, so i used the key got in and the buttons on the doors dont work to unlock the doors either.

The key would also not work to unlock the rear hatch.

Got in and noticed the littel red light on the dash which i think is the security light that normally blinks is now permanently on, whether the car is running, key is in the ignition or not, its always on.

That seemed to be the only problem but tonight when driving (before it got too dark) i noticed that my headlights are also not working and the speedometer no longer works either. Everything else on the dash is fine, and if i pull the light switch back my high beams flash but regular lights wont go on.

AC is also not working but i dont know if thats related or not.

Everything else seems to be working fine, so i dont think its a fuse as every fuse that i thought it might be would have been linked to something else too.

Anyone have any idea what it could be? Id rather not ahve to take it to a dealer to have it checked out but looks like im going to have to as i have no idea at this point.

Chrisfol82 is offline   Reply With Quote Quick reply to this message
Unread 10-25-2010, 03:44 PM   #2
richd
Registered User
2008 KK Liberty 
 
Join Date: Jun 2008
Location: Arizona
Posts: 1,107
This sounds like a BCM problem,everything you mentioned is controlled by the BCM.
richd is offline   Reply With Quote Quick reply to this message
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.
Note: All free e-mails have been banned due to mis-use. (Yahoo, Gmail, Hotmail, etc.)
Don't have a non-free e-mail address? Click here for a solution: Manual Account Creation
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.


Thread Tools


Suggested Threads





Jeep, Wrangler, Cherokee, Grand Cherokee, and other models are copyrighted and trademarked to Jeep/Chrysler Corporation. JeepForum.com is not in any way associated with Jeep or the Chrysler Corp.