post #1 of Old 04-04-2013, 12:31 PM Thread Starter
stone994
Registered User
1997 ZJ 
 
Join Date: Oct 2012
Location: Truro
Posts: 10
electrical nightmare

a friend of mine owns a 2006 kj 3.7 4dr when the key is in it will not start kills everything then after i take my key out it dose wierd stuff like lock and unlock the back window click when i hit the horn but other times it will fire right up and work fine really stumped here and sudjestins would help

stone994 is offline  
post #2 of Old 04-04-2013, 12:40 PM
tjkj2002
Registered User
2002 KJ Liberty 
 
Join Date: Dec 2009
Location: Colorado
Posts: 8,360
Replace the battery.

'02 Liberty sitting on 35" tires,HP44,RockJock60,and AtlasII t-case
tjkj2002 is offline  
post #3 of Old 04-04-2013, 12:44 PM Thread Starter
stone994
Registered User
1997 ZJ 
 
Join Date: Oct 2012
Location: Truro
Posts: 10
batterys new
stone994 is offline  
post #4 of Old 04-04-2013, 01:33 PM
tjkj2002
Registered User
2002 KJ Liberty 
 
Join Date: Dec 2009
Location: Colorado
Posts: 8,360
Quote:
Originally Posted by stone994 View Post
batterys new
Does not mean it's any good.

Could be other issues like a bad connection in the battery terminals,grounds,or the battery cables themselfs.

'02 Liberty sitting on 35" tires,HP44,RockJock60,and AtlasII t-case
tjkj2002 is offline  
post #5 of Old 04-04-2013, 04:47 PM
Bain98xj
Registered User
1998 XJ Cherokee 
 
Join Date: Dec 2009
Location: howell
Posts: 393
Check all power and ground wires. And loose or dirty connection will cause that clean batter terminals and wires
Bain98xj is offline  
post #6 of Old 04-08-2013, 10:34 PM
Lookeee
Registered User
2004 KJ Liberty 
 
Join Date: Dec 2011
Location: Westpoint
Posts: 11
Stone994,

Had something very similar, everything would come on, then the minute you turn the key, boom. All shuts down, cycling back door lock, etc. And like everyone else above, battery. Mine wasn't brand new, but still under warranty, so that was nice. But it was a bad battery, about a year old. Happens all the time on these Lib's, that's why they responded so quickly, lol. Freaky weird, but search for it on here. Hope it's just a bad battery and you don't have to hunt for a bad connection. Good luck!
Lookeee is offline  
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome