daughter's kj won't idle then does idle - JeepForum.com

 
LinkBack Thread Tools
post #1 of 5 Old 09-21-2013, 01:12 PM Thread Starter
Skipper6413
Registered User
2011 KK Liberty 
 
Join Date: Jul 2011
Location: Texarkana
Posts: 337
daughter's kj won't idle then does idle

Ok. Daughter has a 2002 3.7 liter kj that has 125000 miles. My first time seeing it it had the ac compressor go bad and radiator leak. Daughter had it towed and they had removed the compressor. It was shot anyway. I bypassed the compressor and changed the radiator this am. Now it will start and run but won't idle. After disconnecting and connect MAF sensor it now idles. ..thoughts? Maybe sensor going bad?

Skipper6413 is offline  
Sponsored Links
Advertisement
 
post #2 of 5 Old 09-21-2013, 01:14 PM Thread Starter
Skipper6413
Registered User
2011 KK Liberty 
 
Join Date: Jul 2011
Location: Texarkana
Posts: 337
By the way when it runs it isn't rough running at all. Seemed smooth just won't idle then does idle just fine...weird.
Skipper6413 is offline  
post #3 of 5 Old 09-21-2013, 01:14 PM
tommudd
Registered User
2004 KJ Liberty 
 
Join Date: Aug 2008
Location: Central OH/ Kilimanjaro,Tanzania
Posts: 5,629
Have you pulled any of the codes yet to see what comes up ?

04 KJ 4.5 JBA lift, 03 KJ 2.5 JBA coilovers,
tommudd is offline  
post #4 of 5 Old 09-21-2013, 03:37 PM Thread Starter
Skipper6413
Registered User
2011 KK Liberty 
 
Join Date: Jul 2011
Location: Texarkana
Posts: 337
I don't have any fault codes.
Skipper6413 is offline  
post #5 of 5 Old 09-22-2013, 12:32 PM Thread Starter
Skipper6413
Registered User
2011 KK Liberty 
 
Join Date: Jul 2011
Location: Texarkana
Posts: 337
Well, evidently we fixed it. The tow service had disconnected the air intake off the manifold and the PCM had reset itself to run with "open air." When we connected the air tube back, the PCM was still compensating. By pulling the fuse/relay and inserting it, it caused the PCM to release thus fixing it. Anyway it's running very nice now.
Skipper6413 is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.



Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome