Cuts off when i go into drive... help - JeepForum.com
Search  
Sign Up   Today's Posts
User: Pass: Remember?
Advertise Here
Jeep Home Jeep Forum Jeep Classifieds Jeep Registry JeepSpace Jeep Reviews Jeep Gallery Jeep Clubs Jeep Groups Jeep Videos Jeep Events Jeep Articles
Go Back JeepForum.com > Models > Jeep Liberty Forums > KJ Liberty Forum > Cuts off when i go into drive... help

WJ Tube Doors Now Available!*VOTE NOW Help Metalcloak Giveaway an XJ Suspension*TJ 5.25" Speaker Adapters - NalinMFG

Reply
Unread 10-31-2011, 08:20 PM   #1
tn27822
Registered User
2003 KJ Liberty 
 
Join Date: Oct 2011
Location: wilson, nc
Posts: 1
Cuts off when i go into drive... help

2003 Liberty 3.6... Starts great, run good. with my foot on the brake i shift into drive, let my foot off the brake and the jeep jumps forward a bit and cuts off........ i can shift back into park, re-start it and it will not do that again and it runs fine..... let it sit for 5 or 6 hours and the same thing will happen all over again..... please help.....

tn27822 is offline   Reply With Quote
Unread 11-06-2011, 02:00 PM   #2
95BadBoy
Moderator
2005 TJ Wrangler 
 
Join Date: May 2006
Location: Grand Forks, ND
Posts: 2,828
First Post - Welcome to JF -

No answer for your question - but a bump to the top.
__________________
05 TJ RME 42RLE with some things
05 KJ CRD 545RFE, GDE Eco tune, Franky II, Al's 4.5 A-arms, JK Rubi Moabs, Silent Armors 245-70-17's, Spidertrax Adapters, Rola Basket, Fumoto Valve, Pinch welds pounded

FS or FT (2) JK Rubi 17" Moab Rims - really nice shape
Need JK Rear Spare tire bracket for project
95BadBoy is offline   Reply With Quote
Reply

Tags
start-up , torque converter , transmission
Thread Tools


Suggested Threads





Jeep, Wrangler, Cherokee, Grand Cherokee, and other models are copyrighted and trademarked to Jeep/Chrysler Corporation. JeepForum.com is not in any way associated with Jeep or the Chrysler Corp.