Cruise control dont work - JeepForum.com
Search  
Sign Up   Today's Posts
User: Pass: Remember?
Advertise Here
Jeep Home Jeep Forum Jeep Classifieds Jeep Registry JeepSpace Jeep Reviews Jeep Gallery Jeep Clubs Jeep Groups Jeep Videos Jeep Events Jeep Articles
Go Back JeepForum.com > Models > Jeep Liberty Forums > KJ Liberty Forum > Cruise control dont work

Stainless Steel Door Hinge PinsPoly Door Hinge BushingsFS: 2007-2013 Jeep Wrangler "HALO" Angel Eye Kit

Reply
Unread 06-07-2013, 02:15 PM   #1
vincentblood024
Registered User
2005 KJ Liberty 
 
Join Date: Jun 2013
Location: steamboat springs, colorado
Posts: 5
Cruise control dont work

So my cruise control don't work on my 2005 jeep liberty crd and so far I have replaced the clockspring and no good still don't work and theres still no light coming on the dash ive traced the wires the best I can from the steering wheel and can find any breaks, is there a relay or fuse or something im missing I really would like to use the cruise control on this jeep sometime. If anyone has an Idea please let me know thank you Could the transmission output and input speed sensors cause this problem or possibly the instrument cluster being bad since the cruise light don't light up but everthing else works like the odometer and trip meter.


Last edited by vincentblood024; 06-08-2013 at 01:57 AM..
vincentblood024 is offline   Reply With Quote
Unread 06-08-2013, 02:08 AM   #2
Billwill
Registered User
2002 KJ Liberty 
 
Join Date: Jul 2007
Location: South Africa
Posts: 979
Quote:
Originally Posted by vincentblood024 View Post
So my cruise control don't work on my 2005 jeep liberty crd and so far I have replaced the clockspring and no good still don't work and theres still no light coming on the dash ive traced the wires the best I can from the steering wheel and can find any breaks, is there a relay or fuse or something im missing I really would like to use the cruise control on this jeep sometime. If anyone has an Idea please let me know thank you Could the transmission output and input speed sensors cause this problem or possibly the instrument cluster being bad since the cruise light don't light up but everthing else works like the odometer and trip meter.
Lots of things could be causing it not to work....the switches on the steering boss or a brake switch not working properly or a wiring problem.

Download the 2005 Service manual here...includes the wiring diagram and should give you an explanation of how the system works:

http://www.colorado4wheel.com/manuals/Jeep/KJ
__________________
2002 2.5 Export CRD Manual 5 speed.
Billwill is offline   Reply With Quote
Unread 06-08-2013, 02:11 PM   #3
vincentblood024
Registered User
2005 KJ Liberty 
 
Join Date: Jun 2013
Location: steamboat springs, colorado
Posts: 5
no the steering wheel things check out fine with a voltmeter, and all the brake lights and parking lights are on ive taken apart the dash to look at the backside of the instrument cluster but there were no bad wires from there to the firewall. Im still wondering if the instrument cluster itself can cause the light to not come on and the cruise to not work. Or something possibly at the transmission because i cant get the cruise to work at all. The light will also not come on when the accuator test is done its the only one on the instrument cluster besides the 4lo light.
vincentblood024 is offline   Reply With Quote
Unread 06-09-2013, 01:38 AM   #4
Billwill
Registered User
2002 KJ Liberty 
 
Join Date: Jul 2007
Location: South Africa
Posts: 979
Quote:
Originally Posted by vincentblood024 View Post
no the steering wheel things check out fine with a voltmeter, and all the brake lights and parking lights are on ive taken apart the dash to look at the backside of the instrument cluster but there were no bad wires from there to the firewall. Im still wondering if the instrument cluster itself can cause the light to not come on and the cruise to not work. Or something possibly at the transmission because i cant get the cruise to work at all. The light will also not come on when the accuator test is done its the only one on the instrument cluster besides the 4lo light.

There are actually three switches within the brake switch......only one of which is used to turn on the rear brake lights so the fact that your brake lights come on is meaningless.

If you look at the brake switch, pin 1 and pin 2 are normally open and close when the pedal is pushed...this is for the brake lamp.

Pin 3 Violet/White and pin 4 Violet/Yellow are used for the cruise control and should measure closed with the brake pedal off and should be open contact when the pedal is depressed.

Pins 5 and 6 are also normally closed and are used as a secondary brake switch signal and goes to the transmission so this may also have some effect.

This above information is from the 2006 KJ circuit diagrams...may be slightly different to the 2005 model so you need to download the correct diagrams and the manual should also give you a description of how cruise control works
__________________
2002 2.5 Export CRD Manual 5 speed.
Billwill is offline   Reply With Quote
Unread 06-10-2013, 04:35 PM   #5
vincentblood024
Registered User
2005 KJ Liberty 
 
Join Date: Jun 2013
Location: steamboat springs, colorado
Posts: 5
So switched out the brake light switch with a new one and still nothing is happening I know the the dash cruise light does work when you do the accuator test so I still cant figure out why it wont turn on at all the switches in the steering wheel are brand new, brand new clockspring, brand new brake light switch,brand new park light relay and still no cruise or light when I push the buttons the buttons are fine with a voltmeter but so was the brake light do the speed sensors on the transmission have to be working in order for the cruise to work I know that the speedometer works fine. Still at a loss as to what it could be this is the only problem with this jeep and ive fixed all the other problems on it but this one has me stumped if anyone knows of anything that might help I would appericate it
vincentblood024 is offline   Reply With Quote
Unread 06-10-2013, 04:43 PM   #6
NotSoMelloYello
Registered User
2003 TJ Wrangler 
 
Join Date: Mar 2012
Location: Coram, New York
Posts: 272
I had a similar problem in my TJ. There was a vacuum line disconnected from the block. Might want to check that out first.
NotSoMelloYello is offline   Reply With Quote
Unread 06-10-2013, 05:33 PM   #7
vincentblood024
Registered User
2005 KJ Liberty 
 
Join Date: Jun 2013
Location: steamboat springs, colorado
Posts: 5
from what I can tell the cruise on a the diesel is all electronic controlled. This is a very tough problem to figure out lol
vincentblood024 is offline   Reply With Quote
Unread 06-10-2013, 07:56 PM   #8
NotSoMelloYello
Registered User
2003 TJ Wrangler 
 
Join Date: Mar 2012
Location: Coram, New York
Posts: 272
The actuator is electronic too? I've never worked on a diesel before but any car I've ever worked on the cruise control was actuated via vacuum
NotSoMelloYello is offline   Reply With Quote
Unread 06-11-2013, 12:33 AM   #9
vincentblood024
Registered User
2005 KJ Liberty 
 
Join Date: Jun 2013
Location: steamboat springs, colorado
Posts: 5
I cant seem to find a servo of any kind on it. I looked for any broken or none hookeup hoses didn't find any all in good shape. still wondering if there is a control through the throttle because it has a wiring harness coming into it just like the brake switch does, but not sure could maybe be a wire on top the tranny I cant see in the wire loom not sure. This thing has been a pain to try and figure out. Not many people say they know much about the diesel everyone knows the 3.7l lol.
vincentblood024 is offline   Reply With Quote
Unread 06-11-2013, 05:05 AM   #10
Billwill
Registered User
2002 KJ Liberty 
 
Join Date: Jul 2007
Location: South Africa
Posts: 979
Quote:
Originally Posted by vincentblood024 View Post
I cant seem to find a servo of any kind on it. I looked for any broken or none hookeup hoses didn't find any all in good shape. still wondering if there is a control through the throttle because it has a wiring harness coming into it just like the brake switch does, but not sure could maybe be a wire on top the tranny I cant see in the wire loom not sure. This thing has been a pain to try and figure out. Not many people say they know much about the diesel everyone knows the 3.7l lol.
Best place for CRD problems is the CRD section ("Love That Torque") at:

http://www.lostjeeps.com/forum
__________________
2002 2.5 Export CRD Manual 5 speed.
Billwill is offline   Reply With Quote




Jeep, Wrangler, Cherokee, Grand Cherokee, and other models are copyrighted and trademarked to Jeep/Chrysler Corporation. JeepForum.com is not in any way associated with Jeep or the Chrysler Corp.