clutch no longer smooth - JeepForum.com
 
LinkBack Thread Tools
post #1 of 2 Old 07-20-2013, 06:55 AM Thread Starter
davidski
Registered User
2007 KJ Liberty 
 
Join Date: Jun 2013
Location: Baltimore
Posts: 50
clutch no longer smooth

So I am on a 2k mile road trip and my new 07 sport decides to start acting weird. When I start releasing the clutch i now get a not so smooth, gittery shift. Also during reverse, as I've come off the clutch I've heard a squeal. It went away when I gave it gas. The gitters no longer allow for a smooth take off, seems to catch a little and jump. Any ideas? Is this something I should get off the road with and into a shop now? Or should I be fine for a week?

davidski is offline  
Sponsored Links
Advertisement
 
post #2 of 2 Old 07-21-2013, 06:36 PM
flexyxj
Registered User
2009 XK Commander 
 
Join Date: May 2005
Location: Sioux Falls,SD
Posts: 500
Check the fluid in the clutch master cylinder reservoir. Fill as needed and start looking for a leak.....
flexyxj is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.



Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome