Clicking Noise When I Put My 03 Liberty into gear + Radiator ISSUE - JeepForum.com
Search  
Sign Up   Today's Posts
User: Pass: Remember?
Advertise Here
Jeep Home Jeep Forum Jeep Classifieds Jeep Registry JeepSpace Jeep Reviews Jeep Gallery Jeep Clubs Jeep Groups Jeep Videos Jeep Events Jeep Articles
Go Back JeepForum.com > Models > Jeep Liberty Forums > KJ Liberty Forum > Clicking Noise When I Put My 03 Liberty into gear + Radiator ISSUE

All Bilstein shocks & struts - Lowest Prices Ever and Santa Kolak Announces: Kolak Exhaust 20% Off Sale!Introducing MONSTALINER™ UV Permanent DIY Roll On Bed Line

Reply
Unread 05-06-2013, 09:50 AM   #1
IslandJay
Registered User
 
Join Date: May 2013
Location: Oldsmar, Florida
Posts: 9
Clicking Noise When I Put My 03 Liberty into gear + Radiator ISSUE

Need help please! I called my local jeep dealer and they said it isnt a problem. I am not convinced.

Basically my 6cyl 2003 2x4 liberty with 105k makes a clicking noise when I put into F or R gear fresh from start up. Otherwise it does not make the noise when I shift. It is only the initial shift after start up ( and possibly rest)

It makes about 10 super fast clicks. Almost sounds like something is winding up and clicking. There are zero operational issues and it drives and shifts very well.

ALSO I just had the radiator replaced by my local jeep dealer. When I park it and shut it off, I can hear "air escaping" or something decompressing for a few seconds. Now the repair was done about 2 months ago. The other day I noticed my radiator fluid was almost empty.

Thoughts?

Thank you!
Jason

IslandJay is offline   Reply With Quote Quick reply to this message
Unread 05-06-2013, 06:39 PM   #2
tjkj2002
Registered User
2002 KJ Liberty 
 
Join Date: Dec 2009
Location: Colorado
Posts: 8,171
That clicking from the trans is normal,it's the shift solinoids cycling.Mines done it since I drove it off the lot with 3 miles on her.

The radiator issue is not normal and needs to be found and fixed ASAP as the 3.7's do not like to be overheated.
__________________
'02 Liberty sitting on 35" tires,HP44,RockJock60,and AtlasII t-case
tjkj2002 is offline   Reply With Quote Quick reply to this message
Unread 05-07-2013, 01:58 PM   #3
IslandJay
Registered User
 
Join Date: May 2013
Location: Oldsmar, Florida
Posts: 9
The fluid seems to be holding after a few weeks. What would cause it to drain like that after a fresh install? I am assuming the old fluid is drained and replaced?
IslandJay is offline   Reply With Quote Quick reply to this message
Unread 05-07-2013, 03:51 PM   #4
tjkj2002
Registered User
2002 KJ Liberty 
 
Join Date: Dec 2009
Location: Colorado
Posts: 8,171
Quote:
Originally Posted by IslandJay View Post
The fluid seems to be holding after a few weeks. What would cause it to drain like that after a fresh install? I am assuming the old fluid is drained and replaced?
Could not have been bleed correctly and it "burped" which could have been the cause of the low coolant if no leaks were found.Make sure you topped it off with the correct HOAT coolant.
__________________
'02 Liberty sitting on 35" tires,HP44,RockJock60,and AtlasII t-case
tjkj2002 is offline   Reply With Quote Quick reply to this message
Unread 05-08-2013, 01:37 PM   #5
IslandJay
Registered User
 
Join Date: May 2013
Location: Oldsmar, Florida
Posts: 9
Thank you!
IslandJay is offline   Reply With Quote Quick reply to this message
Unread 05-18-2013, 05:05 AM   #6
Kiko247
Registered User
 
Join Date: May 2013
Location: Astoria, New York
Posts: 2
Hey I have. 2002 sport and mine does this clunking sound when I also go from D to P any idea
Kiko247 is offline   Reply With Quote Quick reply to this message
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.
Note: All free e-mails have been banned due to mis-use. (Yahoo, Gmail, Hotmail, etc.)
Don't have a non-free e-mail address? Click here for a solution: Manual Account Creation
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.


Thread Tools






Jeep, Wrangler, Cherokee, Grand Cherokee, and other models are copyrighted and trademarked to Jeep/Chrysler Corporation. JeepForum.com is not in any way associated with Jeep or the Chrysler Corp.