Clicking noise underneath Jeep Liberty 2003 - JeepForum.com
 
LinkBack Thread Tools
post #1 of 4 Old 04-26-2007, 02:49 PM Thread Starter
sharhack
Registered User
 
Join Date: Apr 2007
Location: frankfort
Posts: 3
Clicking noise underneath Jeep Liberty 2003

I have a clicking noise underneath on my Jeep Liberty. It has been there since I used 4 wheel drive this winter. This may be the connection. The Part Time light on the dash keeps blinking on and off. I can only hear the clicking when I am starting out or slowing down. When I push down on the 4wheel drive shifter, it will go off. It acts as if the shifter is not locked in 2 wheel drive. HELP! The noise is bothering me. I am afraid it is something serious.

sharhack is offline  
Sponsored Links
Advertisement
 
post #2 of 4 Old 04-30-2007, 08:46 AM
LandRovering
Registered User
 
Join Date: Apr 2007
Location: Cleveland
Posts: 21
Quote:
Originally Posted by sharhack
When I push down on the 4wheel drive shifter, it will go off. It acts as if the shifter is not locked in 2 wheel drive. HELP! The noise is bothering me. I am afraid it is something serious.
so is your shift handle not going down the whole way? or do you just mean you can push down further and then the light turns off?

bad sensor possibly. been happening to a lot of people it seems.
LandRovering is offline  
post #3 of 4 Old 06-27-2007, 11:07 AM Thread Starter
sharhack
Registered User
 
Join Date: Apr 2007
Location: frankfort
Posts: 3
Clicking noise

Will a new sensor take care of the clicking noise underneath the Jeep or just the light?
sharhack is offline  
post #4 of 4 Old 06-03-2010, 04:22 PM
CG_Doc
Registered User
2003 KJ Liberty 
 
Join Date: Jun 2010
Location: Arlington, VA
Posts: 6
I looked that up in another forum, and they told me that it is the case transfer switch being disconnected as the reason why the part time light is on when you are in normal drive and goes off when you pull into 4WD.
CG_Doc is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.



Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Similar Threads
Thread Thread Starter Jeep Forums Replies Last Post
04 Liberty Won't Start--Clicking Noise? JEEP97TJ KJ Liberty Forum 17 09-10-2013 12:34 PM
Mystery Noise in my 2003 Liberty JFiske KJ Liberty Forum 9 03-08-2010 05:02 PM
2003 Jeep Liberty Renegade USArmy31B KJ Liberty Forum 6 02-17-2009 09:35 PM
HELP 2003 Jeep Liberty DIED!!! nolo263 KJ Liberty Forum 12 03-31-2008 06:17 PM
Jeep Liberty 2003 + PCV valve bclarkuncc KJ Liberty Forum 3 05-19-2006 10:59 AM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome