Clicking noise underneath Jeep Liberty 2003 - JeepForum.com
Search  
Sign Up   Today's Posts
User: Pass: Remember?
Advertise Here
Jeep Home Jeep Forum Jeep Classifieds Jeep Registry JeepSpace Jeep Reviews Jeep Gallery Jeep Clubs Jeep Groups Jeep Videos Jeep Events Jeep Articles
Go Back JeepForum.com > Models > Jeep Liberty Forums > KJ Liberty Forum > Clicking noise underneath Jeep Liberty 2003

Rampage Bowless Soft Top Oconee offroadAlloy USA Still AvailableAdvance Adapters SYE Kits

Reply
Unread 04-26-2007, 02:49 PM   #1
sharhack
Registered User
 
Join Date: Apr 2007
Location: frankfort
Posts: 3
Clicking noise underneath Jeep Liberty 2003

I have a clicking noise underneath on my Jeep Liberty. It has been there since I used 4 wheel drive this winter. This may be the connection. The Part Time light on the dash keeps blinking on and off. I can only hear the clicking when I am starting out or slowing down. When I push down on the 4wheel drive shifter, it will go off. It acts as if the shifter is not locked in 2 wheel drive. HELP! The noise is bothering me. I am afraid it is something serious.

sharhack is offline   Reply With Quote Quick reply to this message
Unread 04-30-2007, 08:46 AM   #2
LandRovering
Registered User
 
Join Date: Apr 2007
Location: Cleveland
Posts: 21
Quote:
Originally Posted by sharhack
When I push down on the 4wheel drive shifter, it will go off. It acts as if the shifter is not locked in 2 wheel drive. HELP! The noise is bothering me. I am afraid it is something serious.
so is your shift handle not going down the whole way? or do you just mean you can push down further and then the light turns off?

bad sensor possibly. been happening to a lot of people it seems.
LandRovering is offline   Reply With Quote Quick reply to this message
Unread 06-27-2007, 11:07 AM   #3
sharhack
Registered User
 
Join Date: Apr 2007
Location: frankfort
Posts: 3
Clicking noise

Will a new sensor take care of the clicking noise underneath the Jeep or just the light?
sharhack is offline   Reply With Quote Quick reply to this message
Unread 06-03-2010, 04:22 PM   #4
CG_Doc
Registered User
2003 KJ Liberty 
 
Join Date: Jun 2010
Location: Arlington, VA
Posts: 6
I looked that up in another forum, and they told me that it is the case transfer switch being disconnected as the reason why the part time light is on when you are in normal drive and goes off when you pull into 4WD.
CG_Doc is offline   Reply With Quote Quick reply to this message
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.
Note: All free e-mails have been banned due to mis-use. (Yahoo, Gmail, Hotmail, etc.)
Don't have a non-free e-mail address? Click here for a solution: Manual Account Creation
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.


Thread Tools


Suggested Threads





Jeep, Wrangler, Cherokee, Grand Cherokee, and other models are copyrighted and trademarked to Jeep/Chrysler Corporation. JeepForum.com is not in any way associated with Jeep or the Chrysler Corp.