Check Engine Light and Loss of Power - JeepForum.com
Search  
Sign Up   Today's Posts
User: Pass: Remember?
Advertise Here
Jeep Home Jeep Forum Jeep Classifieds Jeep Registry JeepSpace Jeep Reviews Jeep Gallery Jeep Clubs Jeep Groups Jeep Videos Jeep Events Jeep Articles
Go Back JeepForum.com > Models > Jeep Liberty Forums > KJ Liberty Forum > Check Engine Light and Loss of Power

Advance Adapters SYE Kits~Artec JK 1 TON SWAP~Truc-Lite LED Headlights! OCONEE OFF-ROAD 706-534-9955

Reply
Unread 12-10-2012, 12:09 PM   #1
aljmiller87
Registered User
 
Join Date: Dec 2012
Location: Leander, Texas
Posts: 1
Check Engine Light and Loss of Power

Hey gang,

Started my 06 CRD in 45 degree whether and immediately noticed the idle sounded off, not quite low/deep enough. I watched the RPMs fluctuate mildly for about 20-30 seconds before it seemed to stabalize (it still didn't have its normal deep rumble).

I thought I noticed some power loss, but didn't try to give my CRD some gas till I got out of my neighborhood. I turned onto a 55 MPH road, gave my CRD a heavy foot on the gas pedal, and then *DEEP THUNK*. Sure enough, I had almost zero acceleration and it took me a while just to get in 45-50mph and couldn't go any faster.

Stopped at the grocery store where I was heading. Turned the car off for 10 min. When I drove home, same issue except this time I noticed the check engine light (it's possible it was on before but I didn't notice as I was concerned with the road and not killing myself while underpowered).

I took it to a look advanced auto and they could not pull any code for the check engine light. Oh, for a couple weeks I had a "LoCool" dash flashing light. This is still happening as well.

Any ideas? I think it might be a fuel pump, but I really don't know much. Thank you!

aljmiller87 is offline   Reply With Quote
Unread 12-11-2012, 01:46 AM   #2
Billwill
Registered User
2002 KJ Liberty 
 
Join Date: Jul 2007
Location: South Africa
Posts: 965
Quote:
Originally Posted by aljmiller87 View Post
Hey gang,

Started my 06 CRD in 45 degree whether and immediately noticed the idle sounded off, not quite low/deep enough. I watched the RPMs fluctuate mildly for about 20-30 seconds before it seemed to stabalize (it still didn't have its normal deep rumble).

I thought I noticed some power loss, but didn't try to give my CRD some gas till I got out of my neighborhood. I turned onto a 55 MPH road, gave my CRD a heavy foot on the gas pedal, and then *DEEP THUNK*. Sure enough, I had almost zero acceleration and it took me a while just to get in 45-50mph and couldn't go any faster.

Stopped at the grocery store where I was heading. Turned the car off for 10 min. When I drove home, same issue except this time I noticed the check engine light (it's possible it was on before but I didn't notice as I was concerned with the road and not killing myself while underpowered).

I took it to a look advanced auto and they could not pull any code for the check engine light. Oh, for a couple weeks I had a "LoCool" dash flashing light. This is still happening as well.

Any ideas? I think it might be a fuel pump, but I really don't know much. Thank you!
The "LoCooL" light means you are low on engine coolant...I hope you have not damaged the engine....there have been known problems whereby the engine overheats due to the low coolant while the temperature gauge sits nicely in the center.

Yo had better fill up with coolant, burb the system and hold thumbs.
__________________
2002 2.5 Export CRD Manual 5 speed.
Billwill is offline   Reply With Quote




Jeep, Wrangler, Cherokee, Grand Cherokee, and other models are copyrighted and trademarked to Jeep/Chrysler Corporation. JeepForum.com is not in any way associated with Jeep or the Chrysler Corp.