Check Engine Light - JeepForum.com
Search  
Sign Up   Today's Posts
User: Pass: Remember?
Advertise Here
Jeep Home Jeep Forum Jeep Classifieds Jeep Registry JeepSpace Jeep Reviews Jeep Gallery Jeep Clubs Jeep Groups Jeep Videos Jeep Events Jeep Articles
Go Back JeepForum.com > Models > Jeep Liberty Forums > KJ Liberty Forum > Check Engine Light

Alloy usa heavy duty ball joint kitsNEW!! HMF 50"-52" light bar mounting brackets!! ZONE 4.25" combo lift for TJ available at Rockridge4w

Reply
Unread 07-24-2005, 07:51 AM   #1
rborgers
Registered User
 
Join Date: May 2002
Location: Memphis, Tn
Posts: 16
Check Engine Light

I had just got back in town after driving about 250 miles today in my liberty CRD. I had parked it and let it sit for about hour when I started it up the check engine light came on. I have put about 4500 miles on the jeep with out any problems until today. I scanned the code and it showed P0299 turbo supercharger under boost and P0401 EGR flow insufficient. I went ahead and drove to the store and back with out any problem. Has any one else experienced this problem, or know what could cause this.

rborgers is offline   Reply With Quote Quick reply to this message
Unread 07-24-2005, 04:38 PM   #2
Diesel Inferno
Registered User
 
Join Date: May 2005
Posts: 337
Since we are more or less Pioneers for the CRD in the US market I think we are all going to be doing a lot of R&D for Chrysler. I would take it in and have it checked before the car erases the code.
__________________
[COLOR=DarkRed]Downers Grove Illinois[/COLOR]
2005 Inferno Red Sport CRD
Diesel Inferno is offline   Reply With Quote Quick reply to this message
Unread 07-25-2005, 01:27 PM   #3
bcnail
Registered User
 
Join Date: Jul 2005
Posts: 2
check engine light

I have a Liberty CRD I purchased at the end of February. My check engine light has been on for over a week. Today I checked the codes: P0299 and P0410 -- I have no idea what P0410 is. The car has just over 6000 miles on it.
bcnail is offline   Reply With Quote Quick reply to this message
Unread 07-26-2005, 08:15 PM   #4
rborgers
Registered User
 
Join Date: May 2002
Location: Memphis, Tn
Posts: 16
Well I got into the dealership yesterday. They reflashed the computer but it was still throwing a CEL. They contacted Chrysler who advised that I needed a new EGR . The tech advised that there is an updated EGR out. They let me drive the Liberty until the EGR comes in, hopefully Friday. Seems to be running a little smother with a little less turbo lag.
rborgers is offline   Reply With Quote Quick reply to this message
Unread 07-27-2005, 05:56 PM   #5
n3qik
Registered User
2013 JK Wrangler 
 
Join Date: Feb 2005
Location: Telford, Pa.
Posts: 179
Well I join the P0299 club this morning. The CEL came on going to work. Sending it to the dealer on Monday.
__________________
Ken from Telford,Pa
Current:2013 4-Door Wrangler Sahara Bright White- 1K miles-Stock
1998 Wrangler w/ 4.0 manual trans-95K miles- Stock
Previous:2012 2-door Wrangler Sport S-"Dozer Clear Coat" w/ manual- Stock-9K Miles Sold 3/2013
2005 Liberty w/ 2.8 Diesel-50K miles- Sold 2/2012
n3qik is offline   Reply With Quote Quick reply to this message
Unread 08-01-2005, 08:19 PM   #6
libil
Registered User
2005 KJ Liberty 
 
Join Date: Jan 2005
Location: n il
Posts: 18
My CEL has been on for four weeks. Week one the dealer blamed it on the fuel cap, then week two, the fuel. After I brought it in and left it over night they said the light was not on. The next day it was back on again. This time it is the EGR. That was two weeks ago, there are 65+ back ordered and none in the system.


Its been two weeks and the "redesigned" EGR is still functioning, time will tell. Mileage is improving with use 11,300, this tank is 24.8mpg.

Last edited by libil; 08-20-2005 at 07:14 PM..
libil is offline   Reply With Quote Quick reply to this message
Unread 08-02-2005, 06:49 PM   #7
n3qik
Registered User
2013 JK Wrangler 
 
Join Date: Feb 2005
Location: Telford, Pa.
Posts: 179
Back from the dealer,codes
P0299- turbo under boost
P0401- minumun EGR flow
P101- Mass air flow single range high

Fixes
Flash TSB 18-018-05
order new EGR valve, 3-4 week wait

CEL came back on half way home from dealer. Still no power idel to 2000 RPMs but it ran a lot better this morning, no dropping RPMs.
__________________
Ken from Telford,Pa
Current:2013 4-Door Wrangler Sahara Bright White- 1K miles-Stock
1998 Wrangler w/ 4.0 manual trans-95K miles- Stock
Previous:2012 2-door Wrangler Sport S-"Dozer Clear Coat" w/ manual- Stock-9K Miles Sold 3/2013
2005 Liberty w/ 2.8 Diesel-50K miles- Sold 2/2012
n3qik is offline   Reply With Quote Quick reply to this message
Unread 08-04-2005, 08:15 PM   #8
rborgers
Registered User
 
Join Date: May 2002
Location: Memphis, Tn
Posts: 16
New EGR

The dealership replaced my EGR valve today. It only took them 4 days to get the new EGR in. Could not have asked for better service, they gave me a loaner and asked to keep my CRD overnight just to test drive it and go over it. I picked it up this morning and managed to put about 80 miles on it running errands. So far it seems to be running great, seems a little smother.
rborgers is offline   Reply With Quote Quick reply to this message
Unread 08-06-2005, 01:18 PM   #9
europachris
Registered User
 
Join Date: May 2005
Posts: 55
How does one get the CEL codes from the computer?

We had our EGR valve replaced several months ago already (CEL, really bad hesitation, etc).

But, on the way home from shopping this a.m., the CEL came on again. I did just fuel it up 5 minutes before that, so I'll check the cap and such, but I made sure it went 3 clicks.

It would be nice to know how to scan the codes and where is a database of the CRD codes I can look at????

Thanks!

Chris
europachris is offline   Reply With Quote Quick reply to this message
Unread 08-07-2005, 11:22 AM   #10
europachris
Registered User
 
Join Date: May 2005
Posts: 55
Well, I did a search here and found the trick to read the codes. This is one thing I LOVE about Chrysler - reading codes with no scanner. My wife's old '94 Shadow was the same way.

Anyway, we got the P0110, P0299, and P0410 codes. Looks like our EGR valve went tits-up again. That's number 2 for us now. Fortunately we really love the CRD, but it's been in the shop multiple times for hesitating, EGR issues, re-flashes, etc. It doesn't instill a lot of confidence that it's going to hold up over the long run.

Many of the issues I've seen here are just dumb assembly/training issues at the plant, but these major failure issues are disturbing.

Well, we'll take her into the dealer next week and get it checked out and ANOTHER EGR valve ordered/installed.

Chris
europachris is offline   Reply With Quote Quick reply to this message
Unread 08-07-2005, 07:33 PM   #11
n3qik
Registered User
2013 JK Wrangler 
 
Join Date: Feb 2005
Location: Telford, Pa.
Posts: 179
Quote:
Originally Posted by europachris
Anyway, we got the P0110, P0299, and P0410 codes. Looks like our EGR valve went tits-up again. That's number 2 for us now. Fortunately we really love the CRD, but it's been in the shop multiple times for hesitating, EGR issues, re-flashes, etc. It doesn't instill a lot of confidence that it's going to hold up over the long run.Chris
I hope you mean P0101 and P0401. They are the codes I have that point to EGR problems.

Got some stupid questions to ask.
1. Are you using any additives/bio-diesel?
2. Do you get your fuel from the same station?
3. Did you get the improved EGR?

Glad I leared how to disconnect the EGR stuff, now just need to do it without setting the CEL.
__________________
Ken from Telford,Pa
Current:2013 4-Door Wrangler Sahara Bright White- 1K miles-Stock
1998 Wrangler w/ 4.0 manual trans-95K miles- Stock
Previous:2012 2-door Wrangler Sport S-"Dozer Clear Coat" w/ manual- Stock-9K Miles Sold 3/2013
2005 Liberty w/ 2.8 Diesel-50K miles- Sold 2/2012
n3qik is offline   Reply With Quote Quick reply to this message
Unread 08-07-2005, 08:13 PM   #12
pbrutsch
Registered User
 
Join Date: Jun 2005
Location: Omaha, NE
Posts: 351
Quote:
Originally Posted by n3qik
Glad I leared how to disconnect the EGR stuff, now just need to do it without setting the CEL.
When you find out be sure to let the rest of us know
__________________
[SIZE=1][b][i]Real[/i][/b] Jeeps don't need no stinkin' spark plugs![/SIZE]
pbrutsch is offline   Reply With Quote Quick reply to this message
Unread 08-07-2005, 08:17 PM   #13
RipTricket
Registered User
 
Join Date: Aug 2005
Location: Oklahoma City, Oklahoma
Posts: 72
How do i check the codes that you all were talking about???
__________________
2005 Silver Renegade w/ BFGoodrich All-Terrain T/A LT235/70R16 tires, light bar, all skid plates (package), Sirius Satelite Radio, w/ an extra set of custom mounted front lights (just for an extra set)!!!

[URL=http://www.cardomain.com/ride/2132086]http://www.cardomain.com/ride/2132086[/URL]
RipTricket is offline   Reply With Quote Quick reply to this message
Unread 08-07-2005, 10:07 PM   #14
europachris
Registered User
 
Join Date: May 2005
Posts: 55
Quote:
Originally Posted by n3qik
I hope you mean P0101 and P0401. They are the codes I have that point to EGR problems.

Got some stupid questions to ask.
1. Are you using any additives/bio-diesel?
2. Do you get your fuel from the same station?
3. Did you get the improved EGR?

Glad I leared how to disconnect the EGR stuff, now just need to do it without setting the CEL.
1. Only additive is Power Service in the grey bottle. I use it all the time in my TDI Jetta with good results.

2. Fuel from several stations in the area. This time it was a new one for us, Mobil, but it has a lot of truck traffic/volume, so the fuel should be fresh.

3. Don't know if we got the improved EGR the first time around. Probably not, as it took the tech a LONG time on the phone with Jeep just to figure out it was the EGR the first time. I'm thinking we were one of the first to have the issue.

I'm not sure if it was the P0101 or P0110, etc. I'm sure it's the same codes as you're getting. Might just be dyslexic .

Chris
europachris is offline   Reply With Quote Quick reply to this message
Unread 08-17-2005, 09:22 PM   #15
danoid
Registered User
2005 KJ Liberty 
 
Join Date: Aug 2005
Posts: 169
Quote:
Originally Posted by RipTricket
How do i check the codes that you all were talking about???
I belive the sequence is 'key on (don't start) - key off - key on - key off - key on - read your odometer.

2005 KJ CRD w/ extra off-road & towing toys
danoid is offline   Reply With Quote Quick reply to this message
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.
Note: All free e-mails have been banned due to mis-use. (Yahoo, Gmail, Hotmail, etc.)
Don't have a non-free e-mail address? Click here for a solution: Manual Account Creation
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.


Thread Tools


Suggested Threads





Jeep, Wrangler, Cherokee, Grand Cherokee, and other models are copyrighted and trademarked to Jeep/Chrysler Corporation. JeepForum.com is not in any way associated with Jeep or the Chrysler Corp.