post #1 of Old 06-01-2013, 06:08 PM Thread Starter
TtownDick
Registered User
2004 KJ Liberty 
 
Join Date: Jun 2013
Location: Tuscaloosa
Posts: 1
CEL Code PO740 Torque Converter Clutch

Just bought a 04 Liberty Sport 4wd on Ebay w 128K miles
Seller said no CEL's BUT....
When I got it CEL was on.
Went to Advance and in addition to to the everpresent O2 sensor codes,
they showed PO740 Torque Converter Clutch out of range.

Anyone have experience with what this means?

Seller's going to check with his mechanic, but hopefully I can get some input here.

PS I noticed some vibration when driving. I was going to have tires balance and front end aligned. Could this be related to the Transmission?

TtownDick is offline  
post #2 of Old 06-02-2013, 07:49 PM
TwoBobsKJ
Senior Member
 
TwoBobsKJ's Avatar
2003 KJ Liberty 
 
Join Date: May 2011
Location: Northern
Posts: 760
Quote:
Originally Posted by TtownDick View Post
Just bought a 04 Liberty Sport 4wd on Ebay w 128K miles
Seller said no CEL's BUT....
When I got it CEL was on.
Went to Advance and in addition to to the everpresent O2 sensor codes,
they showed PO740 Torque Converter Clutch out of range.

Anyone have experience with what this means?

Seller's going to check with his mechanic, but hopefully I can get some input here.

PS I noticed some vibration when driving. I was going to have tires balance and front end aligned. Could this be related to the Transmission?
Hopefully you will get more than a "tail light warranty" from the seller ("when I see your tail lights that's the extent of the warranty...")

That 740 indicates potentially significant issues with the trans. It could be just the torque converter but more likely the overdrive clutch pack is failing or failed. Trans shudder is a typical symptom.

IMO better to find another Liberty that's been maintained properly.

Bob

2003 Renegade, Black
- 3.7L, 42RLE, 4.10's, 4X Guard Trans skid, Factory Engine, T-case, Tank skids, Custom BoulderBars, OME 927/948, Bilsteins, JBA A-Arms & 1/4" top plate, 1 extra rear iso/side, Moabs with Goodyear Duratracs 265/70-16
TwoBobsKJ is offline  
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome